Project

General

Profile

Emulator Issues #1000

"Red Steel" IOCTL_ES_LAUNCH error message

Added by gabrielmorano about 11 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1.Load the Iso
2.
3.

What is the expected output? What do you see instead?
The message is shown, then the game freezes (black screen)

What version of the product are you using? On what operating system?
2811 x32 x64 / 3216 x32 x64 / 3286 x32 x64
Intel(R) Core2Duo 2.53 2gb
GeForce 8400 gt 512
windows vista ultimate

Please provide any additional information below.


Related issues

Is duplicate of Emulator - Emulator Issues #661: Wii-Menu Problems: Address book, Memo, Game Booting, GC Disc Recognition, SettingsFixed

History

#1 Updated by Autoran1 about 11 years ago

Aha... it seems game is searching for WII OS files, you have to dump them from your
own Wii in order to make this error is gone

#2 Updated by gabrielmorano about 11 years ago

I will try to get those, but where do i put them into the emulator in order to test??
Also i dont think the freeze error will be fixed with the OS files (in MGS Twin
Snakes you can bipass the dousens of errors and the game does not crash bit in here
the emulator crash)

#3 Updated by Anonymous about 11 years ago

no, dolphin currently does not emulate es_launch

#5 Updated by marcus about 11 years ago

Well, the best way to go would probably be to run ftpii on your wii and copy the
contents of /title/00000001/00000009 to /sys/wii/title/00000001/00000009
and see if that works. The only problem is that that won't work with a wii running
anything newer than version 3.3 (without Oct 23 update). Of course, you'll also have
to know how to connect to an ftp server and the local IP address of your wii (which
you can find out in the home menu of the hbc). Good luck. Get started with homebrew here:
http://wiibrew.org/wiki/Homebrew_setup

1000 issues! Go dolphin!

#6 Updated by ksg017 over 10 years ago

Was just curious why so many developers state issues as "game issues" when apparently
its not. As stated its something not emulated yet on the emulator. When yall state
its game issues it seems the issues fall out the limelight. This is a error that has
been placed 5 months ago but because it is stated as a "game issue" its disapeared.

#7 Updated by GCNWIIUploader over 10 years ago

a game issue is the right categorization for this because the game is calling the
unemulated command

#8 Updated by skidau almost 10 years ago

  • Status changed from New to Duplicate

This game uses IOCTL_ES_LAUNCH and will be fixed when the Wii Menu is fixed.

Also available in: Atom PDF