Project

General

Profile

Actions

Emulator Issues #10007

closed

Blinking - BEACH SPIKERS (Happening in Vulkan, DirectX 11 and DirectX 12)

Added by tabnk almost 6 years ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

BEACH SPIKERS

Game ID? (right click the game in the game list, properties, info tab)

GBSE8P

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

c18f2fae7fc17adfea6656213c76e097

What's the problem? Describe what went wrong.

Blinking in game.

What steps will reproduce the problem?

Happening in Vulkan, DirectX 11 and DirectX 12. OpenGL is fine.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0-1637

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel CPU
Nvidia GPU (GTX 960)
Windows 10

[PC specs here]

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Fifo log and Screenshot


Files

BEACH SPIKERS.7z (3.25 MB) BEACH SPIKERS.7z FIFO Log tabnk, 01/03/2017 01:54 AM
00000000-1.png (738 KB) 00000000-1.png Screenshot tabnk, 01/03/2017 01:54 AM

Related issues

Is duplicate of Emulator - Emulator Issues #9957: Vulkan: Gecko OS screen renders incorrectlyInvalid

Actions
Actions #1

Updated by Stenzek almost 6 years ago

  • Status changed from New to Accepted

Seems to be a depth test failing issue on the "dark" frames. Disabling fast depth will "band-aid fix" the issue, but interestingly on Vulkan you get the same pattern triangle that we have on Megaman, so I'm wondering if these are related.

Actions #2

Updated by Stenzek about 5 years ago

  • Status changed from Accepted to Duplicate
Actions #3

Updated by Stenzek about 5 years ago

Actions #4

Updated by Stenzek about 5 years ago

Actions #5

Updated by Stenzek about 5 years ago

Actions #6

Updated by kolano over 2 years ago

User recently updated the wiki indicating this was now resolved in Vulkan?

Actions #7

Updated by Stenzek over 2 years ago

I wouldn't be surprised if it was. If I remember correctly the Mega Man issue I mentioned was related was also fixed.

Actions #8

Updated by ZephyrSurfer 6 months ago

This was fixed in Vulkan in 5.0-10636 -> https://dolphin-emu.org/download/dev/5d66377310e839d5e7ced299b7a8c690707594ab/

But this is still broken on Direct3D 11 & Direct3D 12. This game had no issues on D3D for a small period of time in the past.

D3D fixed the issue in 4.0-6422 -> https://dolphin-emu.org/download/dev/0b61a0dfc591cbbac7a450bb8b5a7166c9504e51/

The issue reappeared in 4.0-8709 -> https://dolphin-emu.org/download/dev/48b60649af56253570c3a48edb708cfed8e8c91a/

So this is still broke on D3D backends

Actions #9

Updated by ZephyrSurfer 6 months ago

So can we get this reopened, it's still happening on D3D only.

I also have provided a bisect of when it worked on D3D.

(Might need to rename the issue to remove reference to Vulkan.)

Actions

Also available in: Atom PDF