Project

General

Profile

Emulator Issues #10014

Harry Potter: PoA freeze completely for several seconds

Added by azteca about 4 years ago. Updated 6 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
Yes
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Harry

Game ID? (right click the game in the game list, properties, info tab)

GAZE69

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

7a064f4fcdd9a320b626899c3cc41200

What's the problem? Describe what went wrong.

[Description here]

What steps will reproduce the problem?
Load to main menu. Start new game. After opening cutscene of trio on train talking about Professor Lupin, Ron runs down hallway and you assume control of Harry. Game then stops completely for several seconds before resuming. Same thing happened as I fought my way through the train to Malfoy, the book, etc.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0-1644

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel 4770K 3.5GHz // Nvidia GTX 770 2GB //Corsair Vengeance 16GB DDR3 1600MHz // Windows10 x64

**Is there any other relevant information?
https://www.youtube.com/watch?v=h249SnlgoP0

[Anything else here]


Related issues

Has duplicate Emulator - Emulator Issues #11220: Harry Potter and the Prisoner of Azkaban drops to 0 FPS during in-engine cutscene to gameplay transitions. Duplicate

Is duplicate of Emulator - Emulator Issues #11717: Frequent JIT cache flushing in some games on AArch64Accepted

History

#1 Updated by JosJuice about 4 years ago

Does both the FPS and VPS drop, or only the FPS?

#2 Updated by azteca about 4 years ago

JosJuice wrote:

Does both the FPS and VPS drop, or only the FPS?

VPS drops as well. All the way down to 13 when I tried it just now.

#3 Updated by JosJuice about 4 years ago

  • Status changed from New to Questionable
  • Relates to performance changed from No to Yes

Normally I would just write this off as shader compilation stuttering or something, but the pause seems abnormally long...

#4 Updated by azteca about 4 years ago

JosJuice wrote:

Normally I would just write this off as shader compilation stuttering or something, but the pause seems abnormally long...

Here is a video that is a little longer to show multiple stops - a couple in hallway, then with the book, then when facing Malfoy. I included the technical overlay which might be distracting but hopefully can give somebody a clue.

https://www.youtube.com/watch?v=luJeB763CV4

#5 Updated by JosJuice about 4 years ago

That link doesn't work for me. It says "This video is unavailable."

#6 Updated by JosJuice about 4 years ago

It works now.

#7 Updated by azteca about 4 years ago

azteca wrote:

JosJuice wrote:

Normally I would just write this off as shader compilation stuttering or something, but the pause seems abnormally long...

Here is a video that is a little longer to show multiple stops - a couple in hallway, then with the book, then when facing Malfoy. I included the technical overlay which might be distracting but hopefully can give somebody a clue.

https://www.youtube.com/watch?v=luJeB763CV4

Note that when the stops occur several items in the overlay drop down to 0 for several seconds.

#8 Updated by JMC4789 about 4 years ago

  • Status changed from Questionable to Accepted

Oh yeah, it drops to 0 FPS during this. I don't know if it's generating shaders, or it's smashing our JIT cache, but, I've reproduced it.

I don't know whether I want to keep this open or not though. I don't see the harm, I guess. Accepting.

#9 Updated by azteca over 2 years ago

EDIT: Issue persists as of June 3, 2018 Progress Report build.

#10 Updated by SonicFreak94 over 2 years ago

For what it's worth, the console shows:

core\powerpc\jit64\jit.cpp:597 W[PowerPC]: flushing far code cache, please report if this happens a lot

every time the performance drop occurs.

#11 Updated by JMC4789 over 2 years ago

Yeah, I looked into this and it's one of those games that causes lots of flushing.

#12 Updated by JosJuice 6 months ago

  • Has duplicate Emulator Issues #11220: Harry Potter and the Prisoner of Azkaban drops to 0 FPS during in-engine cutscene to gameplay transitions. added

#13 Updated by JosJuice 6 months ago

#14 Updated by JosJuice 6 months ago

  • Status changed from Accepted to Duplicate

Also available in: Atom PDF