Project

General

Profile

Emulator Issues #10051

Launching WADs is broken and crashes Dolphin

Added by leoetlino over 3 years ago. Updated over 3 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-1802
Fixed in:
5.0-2164

Description

Game Name?

Anything that uses CNANDContentDataBuffer

What's the problem? Describe what went wrong.

Dolphin will crash whenever it's trying to launch a WAD. Running a debug build reveals that it's crashing in CNANDContentDataBuffer::GetRange with a out-of-bounds vector read.

This issue only happens on Windows. I failed to reproduce this on Linux.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

I haven't bisected this yet, but it wasn't present in 5.0-1798.

History

#1 Updated by leoetlino over 3 years ago

This doesn't seem to happen for all WADs, actually.

I tried an N64 VC game and it worked

#2 Updated by JMC4789 over 3 years ago

  • Status changed from New to Accepted

I think it's just the Homebrew Channel Wad that's broken now.

#3 Updated by JMC4789 over 3 years ago

  • Status changed from Accepted to Fixed

Reportedly Fixed.

#4 Updated by JosJuice over 3 years ago

  • Regression changed from No to Yes
  • Regression start set to 5.0-1802
  • Fixed in set to 5.0-2164

Also available in: Atom PDF