Project

General

Profile

Emulator Issues #10054

Silent Hill no snow on any graphics backend

Added by iwubcode almost 3 years ago. Updated over 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Silent Hill Shattered Memories

Game ID? (right click the game in the game list, properties, info tab)

R5WEA4

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

91e38be1fa210ae951ef4170cac06a70

What's the problem? Describe what went wrong.

Snow does not render on any backend. This is what it should look like: http://abload.de/img/ezgif.com-optimize6psr1.gif
(attached for screencapture on Dolphin at 1x)

What steps will reproduce the problem?

Start the game, play about 15mins until you can walk around (and use the flashlight) and see there's no snow. Or use the fifolog.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Tested on:

4.0-5993
4.0-7892
5.0-25
5.0-1230
5.0-1458
5.0-1480
5.0-1519
5.0-1850

What are your PC specifications? (CPU, GPU, Operating System, more)

6700k
rx480
Windows 10
16gb ram

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

I'll point at a fifolog someone else posted on reddit. I think we should also put this on the fifoCI bot but maybe that's a separate issue?

http://www35.zippyshare.com/v/vNvU9nM2/file.html

silent_hill_no_snow.JPG (130 KB) silent_hill_no_snow.JPG iwubcode, 01/17/2017 02:22 AM
efb_frame_8.png (78.9 KB) efb_frame_8.png efb dump front of diner mimimi, 04/22/2017 06:29 PM
SHLPA4-1.png (888 KB) SHLPA4-1.png screenshot front of diner mimimi, 04/22/2017 06:30 PM
efb_frame_434.png (24.6 KB) efb_frame_434.png efb dump streetcorner mimimi, 04/22/2017 06:30 PM
SHLPA4-2.png (835 KB) SHLPA4-2.png screenshot streetcorner mimimi, 04/22/2017 06:30 PM
5831
6023
6024
6025
6026

History

#1 Updated by JMC4789 almost 3 years ago

I have a suspicion that this is a CPU error of some sort rather than a GPU error... but that's pure speculation.

#2 Updated by mstreurman almost 3 years ago

I remember it working but dissapearing every now and then in the version that fixed the biggest issue (I believe it was slowness) on DX12 and OGL.

#3 Updated by JMC4789 almost 3 years ago

  • Status changed from New to Accepted

#4 Updated by iwubcode almost 3 years ago

Just posting the findings for now (in case someone else has some bright ideas):

  • If you turn off the hack "store efb copies to texture only" snow will appear but if you toggle it on and off then you won't see it until you change areas
  • The issue seems to go away when you stop overwrite the address pointer in TextureCacheBase, this gives you the same functionality as unchecking "store efb copies to texture only" but without the slowdown. This isn't the "fix" because other games are obviously using this logic. We were not able to determine what games were using this logic.

[Tested on Vulkan]

#5 Updated by mimimi over 2 years ago

6023
6024
6025
6026

iwubcode pointed out that the snow in silent hill kinda works, if Dolphin doesn't clear the underlying memory for efb copies when only doing efb to texture and skipping the copy to the wii's memory. (source: https://github.com/dolphin-emu/dolphin/pull/4913)

From there i tracked it down a bit further. If the copy to memory is done for a certain 256x256 efb copy, or at least the memory is not cleared, the snow shows up in efb to texture only. This efb copy looks a bit like a minimap, see screenshots. So i assume the game uses this efb copy to determine where it should snow and where not.

PS: This efb copy is only updated every few steps you take, which fits tothe behavior when toggling between efb to texture and efb to ram. After such a toggle, you need to move a few steps, until the change becomes active and it either starts to snow or stops snowing.

#6 Updated by JMC4789 over 2 years ago

  • Status changed from Accepted to Invalid

EFB2RAM fixes the snow, and the only way to make snow render on EFB2Tex is STILL rendering it wrong, just in another way.

Also available in: Atom PDF