Project

General

Profile

Emulator Issues #10062

Red Steel 2 hangs

Added by lmello over 3 years ago. Updated over 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Red Steel 2

Game ID? (right click the game in the game list, properties, info tab)

RD2E41

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

07a84764ce2996f2caf623daae4a4ef3

What's the problem? Describe what went wrong.

Emulation halts, screen goes black, entire system hangs

What steps will reproduce the problem?

Shortly after the intro.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Dolphin 5.0-2174

The game used to work with stable 5.0 release.

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i5 4690 @ 3.5Ghz x 4 (turbo boost enabled - up to 3.90Ghz)

Radeon R7 250E

Manjaro Linux, kernel 4.9.2, mesa 13.0.3

History

#1 Updated by PEmu over 3 years ago

Can you find the build where it stopped working?

#2 Updated by lmello over 3 years ago

PEmu wrote:

Can you find the build where it stopped working?

I'd been using the stable release 5.0 for long... only to test Spyborg textures - see https://bugs.dolphin-emu.org/issues/10041 - I was told to run the latest git version. I don't think I'll be able to build and test every build in between.

How can I upload a proper log file here?

#3 Updated by lmello over 3 years ago

When the system hanged it bleeps and the log shows this:

56:45:397 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: << RVL_SDK - GX    release build: Feb 27 2009 10:04:13 (0x4302_145) >>
56:46:405 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: queue overflow in "K3D_init_WII.cpp" on line 2778.
56:46:405 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 
56:46:405 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: Address:      Back Chain    LR Save
56:46:405 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80560e60:   0x80560ef0    0x802c484c
56:46:405 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80560ef0:   0x80560f00    0x80298d18
56:46:405 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80560f00:   0x80560f40    0x80298698
56:46:405 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80560f40:   0x80560f60    0x8029864c
56:46:405 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80560f60:   0x80561240    0x8033a748
56:46:406 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80561240:   0x80561260    0x802c8bf4
56:46:406 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80561260:   0x80561268    0x800238d8
56:46:406 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80561268:   0x80561278    0x800238d8
56:46:406 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80561278:   0x80561288    0x80023844
56:46:406 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80561288:   0x80561298    0x80024920
56:46:406 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x80561298:   0x805612b8    0x8006cd68
56:46:406 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x805612b8:   0x805614e8    0x8000733c
56:46:406 Core/HW/EXI/EXI_DeviceIPL.cpp:337 N[OSREPORT]: 0x805614e8:   0xffffffff    0x800060f8

#4 Updated by lmello over 3 years ago

Well,

I deleted the cache and configuration files and rebuilt Dolphin revision 2207. The emulator nor the system hangs anymore, but performance suffers compared to the 5.0 release. It has something to do with audio, since when I disable audio output the game runs @ 100%.

With 5.0 using I was able to run the game @ 100% with sound, using the pulseaudio backend.

#5 Updated by JMC4789 over 3 years ago

  • Status changed from New to Invalid

You probably changed some configuration file by deleting everything. I'm unable to reproduce any performance difference. If you need more support regarding performance, I recommend trying out the forums; if you're using HLE audio, there's no reason for audio to slow you down and that sounds like a fault within your system.

Also available in: Atom PDF