Project

General

Profile

Emulator Issues #10071

Pausing and stepping in debug mode often crashes the game

Added by TheGag96 over 3 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Smash Bros. Brawl (Project M Netplay v3)

Game ID? (right click the game in the game list, properties, info tab)

RSBE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

d18726e6dfdc8bdbdad540b561051087

What's the problem? Describe what went wrong.

Pausing emulation while in debug mode often corrupts the callstack and crashes the game when resumed.

What steps will reproduce the problem?

Load up PM in debug mode. Set a breakpoint, trigger it, maybe step through some code (though you can get it to crash without it).

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

I'm on 5.0-2260 now, but this has been happening since 5.0 stable.

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel i5-750, nVidia GTX 770, Windows 8.1

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Not really...


Related issues

Is duplicate of Emulator - Emulator Issues #10132: Breakpoints crash game after steppingFix pending

History

#1 Updated by TheGag96 over 3 years ago

Aw crap, can a mod change the title to this? I'm sure I put this in the box: "Pausing and stepping in debug mode often crashes the game"

#2 Updated by parlane over 3 years ago

  • Subject changed from [Short description of your bug here (~10 words)] to Pausing and stepping in debug mode often crashes the game

#3 Updated by sepalani about 3 years ago

@TheGag96
Does the PR #5274 fix the issue?

#4 Updated by leoetlino over 2 years ago

#5 Updated by leoetlino over 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF