Project

General

Profile

Emulator Issues #10107

Garbled transition in Paper Mario TTYD

Added by wartomato almost 3 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Paper Mario: The Thousand Year Door

Game ID? (right click the game in the game list, properties, info tab)

G8MP01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

81321e8256205e3cfb71257e6ba2970f

What's the problem? Describe what went wrong.

During a certain cutscene in the game (shortly after the end of chapter 1), Bowser will ride his clown car out of the castle, "ripping" through the wall behind him (true to the game's paper aesthetic) and flying off into the background. Normally the game would apply an effect to a wall texture to simulate the ripping, but in this case instead of showing the proper texture, it's a garbled mess.
The FPS also drop to between 30-50 as long as the glitch is on screen (meaning the sudden lag goes away as soon as that part of the cutscene ends)
I'm pretty sure this ripping effect is unique to this cutscene, so the glitch probably has to do with the emulation of this particular effect.

What steps will reproduce the problem?

Start up the game, play through the first few areas of the game until the boss of chapter 1 is beaten, get through the cutscenes that ensue until the cutscene in Bowser's castle begins, and the glitch inevitably happens

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

I started off on one of the developer builds (5.0-1xxx, can't remember the exact number), then after noticing the issue I tried several of the newer builds to see if any of them fixed the problem. Ended with the newest build at the time of writing, 5.0-2569
I first played through the game on the stable 4.2.0 build some time ago, which didn't have this exact problem, but it did however have similar glitches in other cutscenes or specific parts of the game that have since been fixed.

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel i5-6500 CPU @3.20GHz (Quad-Core)
NVidia GeForce GTX 970 GPU
32GB RAM
Windows 7 Ultimate, x64

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

I'm using all of the configuration settings listed in the game's wiki page (so none of the other transition effects in the game are glitched like this, and in theory this shouldn't be happening either).
I've tested the glitch on the Direct3D11 renderer, but I can't really test the glitch in OpenGL because it seems to distort all of the 3D graphics in the game to the point of being unplayable
Here's a screenshot of the glitch:
http://imgur.com/a/lnf8O
Curiously, the garbled texture is always the exact same... And it looks like it might be an extremely glitched version of the title screen texture. No idea why.
Also I'm not sure if it changes anything, but I'm playing on the PAL version of the game.


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 almost 3 years ago

Try using single core; it worked for me on my GTX 1070 not too long ago. There are certain timing things on dualcore that are simply broken. If you have a savefile right near it, I can always experiment with it if that doesn't work.

#2 Updated by wartomato almost 3 years ago

JMC4789 wrote:

Try using single core; it worked for me on my GTX 1070 not too long ago. There are certain timing things on dualcore that are simply broken. If you have a savefile right near it, I can always experiment with it if that doesn't work.

alright, apparently switching to single core fixes the visual glitch, but the FPS still drop to about 40 as long as the effect is on screen...
i'm not too sure how to share my entire save, but i did take a save state near the beginning of the cutscene (again, it's for the PAL version, i'm not sure if it'll work on the US release). just get through the dialogue and you'll see the part that glitches for me:
https://www.dropbox.com/s/n3x7ep5fvwbqres/paper.sav?dl=0

#3 Updated by JMC4789 over 2 years ago

  • Status changed from New to Duplicate

Dualcore is known to be bad at almost everything.

#4 Updated by JMC4789 over 2 years ago

Also available in: Atom PDF