Project

General

Profile

Emulator Issues #10113

DOL-001 1.0 USA ipl detected as JAP ipl

Added by ichee about 2 years ago. Updated 5 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

Dolphin gives a warning when booting Gamecube game with 1.0 ipl in USA folder with skip bios unchecked.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0 up to current master 5.0-2577

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel 4790k overclocked @ 4.7Ghz, Nvidia GTX Titan X (Maxwell), Windows 10 Pro AU, Samsung 950 Pro NVMe

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

crc32 6DAC1F2A

md5 FC924A7C879B661ABC37CEC4F018FDF3

sha1 A1837968288253ED541F2B11440B68F5A9B33875

All correct according to redump. Also, the 1.0 USA ipl is also listed as JAP ipl on redump

error.PNG (3.25 KB) error.PNG ichee, 02/24/2017 04:34 PM
redump_gc_bios.dat (1.77 KB) redump_gc_bios.dat ichee, 02/24/2017 04:37 PM
5878

Related issues

Is duplicate of Emulator - Emulator Issues #11467: GameCube IPL BIOS data is wrongFixed

History

#1 Updated by JMC4789 about 2 years ago

Sounds like we have another BIOS to add to our database in all likelihood. We fall back to NTSC-J upon unknown hashes.

#2 Updated by ichee about 2 years ago

Can this be added easily? Any other information needed for verification?

#3 Updated by JMC4789 over 1 year ago

  • Status changed from New to Accepted

I think someone is working on this actually.

#4 Updated by JosJuice 5 months ago

#5 Updated by JosJuice 5 months ago

  • Status changed from Accepted to Duplicate

Also available in: Atom PDF