Project

General

Profile

Emulator Issues #10131

radv: graphical glitches on mk8

Added by jdruel over 2 years ago. Updated about 2 years ago.

Status:
Working as intended
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Mario Kart Wii

Game ID? (right click the game in the game list, properties, info tab)

RMCP01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

2cdde2ef08e04daf4e8347fcf2a68dae

What's the problem? Describe what went wrong.

There's a big white rectangle on the left upper part of the screen when in a race + the position doesn't display + the items don't display + the track is missing

What steps will reproduce the problem?

Launch any race with ay character

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0-2684

What are your PC specifications? (CPU, GPU, Operating System, more)

i7 4770k, AMD Fury, latest amdgpu drivers (git version)+radv (git version)

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]

Maybe it's a bit early to report bugs related to radv. Things are certainly improving a lot: it used to crash my whole system. I can now go in-game. Simple games seem perfect (dragon's lair for ex). Others are rather good (mario super tennis), but with some glitches.

RMCP01-3.png (950 KB) RMCP01-3.png jdruel, 03/01/2017 04:25 PM
RMCP01-4.png (918 KB) RMCP01-4.png jdruel, 03/01/2017 04:25 PM
2017-06-11-MK-Vulkan-RoundVertexOff.png (1.76 MB) 2017-06-11-MK-Vulkan-RoundVertexOff.png jdruel, 06/11/2017 12:06 PM
2017-06-11-MK-Vulkan-RoundVertexOn.jpg (642 KB) 2017-06-11-MK-Vulkan-RoundVertexOn.jpg jdruel, 06/11/2017 12:06 PM
2017-06-11-MK-OGL-IgnoreFormatChangeOn.png (1.98 MB) 2017-06-11-MK-OGL-IgnoreFormatChangeOn.png jdruel, 06/11/2017 12:18 PM
5896
5897
6122
6123
6124

History

#1 Updated by jdruel over 2 years ago

I suppose this is more related to the radv driver, so I created a bug report here with a few fifo files
https://bugs.freedesktop.org/show_bug.cgi?id=100430

#2 Updated by jdruel about 2 years ago

6122
6123
6124

Trying today on mesa stable 17.1.2
Trying the "round vertex" option makes a big difference in behaviour.
With this option on: I have a black screen until the race track starts to display. Then I have a sharp picture and a little black square.
With this option off: I can always see the screen (=it's never black). On the tracks, I have a big square in top left corner.

Finally, I tried with the OGL backend."round vertex" has little influence, but I noticed a slight purple square in top left corner with "IgnoreFormatChange" On (same size as with vulkan, but less visible). It completely disappears, with "IgnoreFormatChange" Off.

Hope this gives the dev some clues.

#3 Updated by JMC4789 about 2 years ago

  • Status changed from New to Working as intended

This bug has been reported to the driver team. there's nothing more to do for us. Sorry. Everything is working as intended on our side.

Also available in: Atom PDF