Project

General

Profile

Emulator Issues #10157

Gradius ReBirth flickering sprites

Added by scoutprotoss almost 3 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Gradius ReBirth

Game ID? (right click the game in the game list, properties, info tab)

WGDEA4

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

940bbb0ab4547a7aa3829875343744c0

What's the problem? Describe what went wrong.

Enemies with multiple sprites (most noticeable on turrets and ships that may appear red to signify being able to drop powerup when destroyed) will flicker inbetween states. The issue is gone if "Enable Dual Core" option is disabled.

What steps will reproduce the problem?

  • Check "Enable Dual Core" config option.
  • Start a game, pay attention to the sentries and ducky turrets.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0
5.0-2973

What are your PC specifications? (CPU, GPU, Operating System, more)

  • CPU: Intel i7-4790
  • GPU: NVIDIA GTX 1060 6GB
  • RAM: 16 GB
  • OS: Windows 10

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Video demonstration:
https://www.youtube.com/watch?v=bFnc7ddrjq8


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 almost 3 years ago

  • Status changed from New to Duplicate

Dualcore is notably buggy as it leaks the host state into the game state.

Issues like these should be expected whenever timings matter.

#2 Updated by JMC4789 almost 3 years ago

#3 Updated by JMC4789 almost 3 years ago

#4 Updated by JMC4789 almost 3 years ago

#5 Updated by JosJuice almost 3 years ago

#6 Updated by JosJuice almost 3 years ago

Also available in: Atom PDF