Project

General

Profile

Emulator Issues #10169

Prince of persia sands of time - Black screen in Vulkan

Added by LuismaSP over 4 years ago. Updated almost 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Prince of persia sands of time PAL (GPTP41)

What's the problem? Describe what went wrong.

Using Vulkan backend causes black screen (Sound works) other backends like OpenGL or DX12 works.

What steps will reproduce the problem?

Load game using Vulkan backend.

Using Dolphin 5.0-3073


Related issues

Is duplicate of Emulator - Emulator Issues #10301: Dolphin outputs no video on Vulkan when using Real XFB on some systemsFixed

History

#1 Updated by Helios over 4 years ago

You didn't tell us what your graphics card is on a graphics issue.

#2 Updated by LuismaSP over 4 years ago

Helios wrote:

You didn't tell us what your graphics card is on a graphics issue.

Sorry, it's a GTX 970, 4GB GDDR5. But i don't think that the problem is the graphics card. The game works ok with all the other backends, and i have a lot of games in my dolphin's library, all tested with different backends, "including vulkan"

#3 Updated by LuismaSP over 4 years ago

Helios wrote:

You didn't tell us what your graphics card is on a graphics issue.
My other pc specs:

I7 4790k 4,5 Ghz
16 GB DDR3

#4 Updated by Stenzek over 4 years ago

Looking at the gameini, it seems this title needs RealXFB.

IIRC there was an issues on some systems where this resulted in no visual output, but I was never able to reproduce it on any of the cards I tried (both Kepler and Maxwell).

Random thing to try, after booting the game, open the graphics dialog and uncheck/re-check realxfb, I'm wondering if it's something to do with it not being enabled correctly through gameinis. Otherwise, I'm out of ideas, since I can't reproduce/debug the issue.

#5 Updated by LuismaSP over 4 years ago

Stenzek wrote:

Looking at the gameini, it seems this title needs RealXFB.

IIRC there was an issues on some systems where this resulted in no visual output, but I was never able to reproduce it on any of the cards I tried (both Kepler and Maxwell).

Random thing to try, after booting the game, open the graphics dialog and uncheck/re-check realxfb, I'm wondering if it's something to do with it not being enabled correctly through gameinis. Otherwise, I'm out of ideas, since I can't reproduce/debug the issue.

Nope, enabling/disabling Real XFB doesn´t fix this. Tested too with Real XFB all the time.

Excuse my ignorance, but if the problem were in XFB, then no one of the video backends should work...isn't that so?

#6 Updated by markwest76 over 4 years ago

I think you cannot see any differences because in the beginninig of the game there's a video that needs real XFB, so selecting virtual XFB at first causes to show a black screen as well, but if you keep on pressing the start key on the joypad you'll end up seeing the menu screen; with Vulkan Real XFB instead there will always be a black screen (on my system Real XFB doesn't work with the Vulkan backend, and I think that your system PC has the same problem).

#7 Updated by JosJuice over 4 years ago

  • Is duplicate of Emulator Issues #10301: Dolphin outputs no video on Vulkan when using Real XFB on some systems added

#8 Updated by JosJuice over 4 years ago

  • Status changed from New to Duplicate

#9 Updated by LuismaSP almost 4 years ago

@

LuismaSP wrote:

Stenzek wrote:

Looking at the gameini, it seems this title needs RealXFB.

IIRC there was an issues on some systems where this resulted in no visual output, but I was never able to reproduce it on any of the cards I tried (both Kepler and Maxwell).

Random thing to try, after booting the game, open the graphics dialog and uncheck/re-check realxfb, I'm wondering if it's something to do with it not being enabled correctly through gameinis. Otherwise, I'm out of ideas, since I can't reproduce/debug the issue.

Nope, enabling/disabling Real XFB doesn´t fix this. Tested too with Real XFB all the time.

Excuse my ignorance, but if the problem were in XFB, then no one of the video backends should work...isn't that so?

This can be closed, because the new and AWESOME hybrid XFB.

Also available in: Atom PDF