Project

General

Profile

Emulator Issues #10171

Paper mario ttyd broken save files

Added by Guitarkory1 about 3 years ago. Updated almost 3 years ago.

Status:
Fixed
Priority:
High
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-4788

Description

Paper mario ttyd

Game ID? (right click the game in the game list, properties, info tab)

GM8E01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

db9a997a617ee03bbc32336d6945ec02

What's the problem? Describe what went wrong.

After I get the stone keys, the memory card gets corrupted and I have to get the stone keys over again. I started a new game 2 times on my old memory card, and I have started 1 time on a new memory card.

What steps will reproduce the problem?
1. play through game normally
2. get the stone keys and save afterwords
3. restart game after saving

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

version 5.0-3088

What are your PC specifications? (CPU, GPU, Operating System, more)
Windows 10 anniversary
intel 4720-HQ
nvidia 960m 4gb

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

There were no error messages or panic alerts during this issue. All of my game settings are normal (stock settings) , no over or underclock. No cheats are being used either.

MemoryCardA.USA1.USA.raw.zip (40.2 KB) MemoryCardA.USA1.USA.raw.zip Guitarkory1, 03/28/2017 02:44 AM
new build broken.png (3.37 KB) new build broken.png All newer builds give this invalid read. saving seems to work, but when I open the game, the progress is gone Guitarkory1, 03/30/2017 02:32 AM
old build works fine.png (4.34 KB) old build works fine.png The old builds still give a invalid read, but work great Guitarkory1, 03/30/2017 02:32 AM
01-GCCP-FFCC.gci (176 KB) 01-GCCP-FFCC.gci Year 2, right in front of Goblin Wall Korados, 04/01/2017 11:00 PM
5934
5935

History

#1 Updated by Guitarkory1 about 3 years ago

For some reson, when I save at this point at this location: the memory card creates a new save file, and there are 2 paper mario save files on my memory card. I guess I can use save states, but its not really ideal. I have to start a new game now. here is the card if it helps.

#2 Updated by Guitarkory1 about 3 years ago

I actually found a fix to the problem, dolphin 5.0 works properly, so Ill just use that for this game for now.Sorry to bother you guys.

#3 Updated by JMC4789 about 3 years ago

Well, if Dolphin 5.0 works properly and the latest dev builds don't, can you please find out which development build broke it through bisecting. If there's something corrupting saves, that'd be incredibly important to find out since the development builds are newer than 5.0.

#4 Updated by Guitarkory1 about 3 years ago

I absolutely can do some digging. It may take a while to do, Its been broken for at least a month or so

#5 Updated by Guitarkory1 about 3 years ago

This took a while: so far I know that somewhere in between builds 581 and 215 there was a change that caused this issue. I still have yet to find the specific build, but will continue to dig.

#6 Updated by Guitarkory1 about 3 years ago

Last working build was 530. First broken build was 540. So either 532 (not a windows build) that broke the game, or build 540 broke the game.
Conjecture/side note: I noticed a difference in invalid reads when testing the older builds and newer builds, they both produce invalid reads in the room with the gold fuzzy when entering the room from one of the side rooms (but not the pipe). The older builds 530 and older give 0x******* where the stars are a seemingly random number, and the newer builds (540 and newer) give a 0x0000000. I am wondering if this change in invalid reads also affected save files.

#7 Updated by JMC4789 about 3 years ago

  • Status changed from New to Questionable
  • Assignee set to degasus
  • Priority changed from Normal to High

That's the Dynamic BAT pull request, which should affect a savefile at all. Can you try turning off panic handlers and seeing if it works fine.

#8 Updated by JosJuice about 3 years ago

JMC: If I haven't misunderstood it, writing into 0x00000000 will overwrite the game ID in RAM, meaning that any save data written after may be identified as the wrong game. So it seems like there's some problem that makes the game write to somewhere it shouldn't write to, and the dynamic BAT change just changed which memory location it writes to. I wonder if this is related to what many people have reported happening in Final Fantasy: Crystal Chronicles...

#9 Updated by JMC4789 about 3 years ago

Now that's interesting as hell.

#10 Updated by Korados about 3 years ago

Now you got my attention, too! I always had the Final Fantasy Crystal Chronicles saving problem and
never could play it well on Dolphin. The saving worked just one time but this was years ago.

Concerning TTYD, I experienced that Dophin crashed after collecting the Sun and Moon Stones
and going into the room with the Golden Fuzzy. But the memory card wasn't corrupted after this.

#11 Updated by Guitarkory1 about 3 years ago

Sorry guys, I just got back from work and read your stuff. I can post some screenshots of the panic handlers from both the non working and working builds in a little bit. But yes, it is saving the file in a new location on the memory card, the memory card I posted has 2 paper mario saves blocks on it, which should be impossible.

#12 Updated by Guitarkory1 about 3 years ago

5934
5935

Did someone say final fantasy crystal chronicles? I own the game but haven't ripped it off the disc yet. if someone has a save file for it where the save corruption happens I can test that game to.

#13 Updated by Korados about 3 years ago

I can play FFCC! When I get the saving problem again, I'll upload the saves for you.

#14 Updated by Korados about 3 years ago

Okay, I played FFCC again and instead of the saving problem, I encountered
the other bug I'm having for some years! I'm not sure if I should post it here, but since we were talking about this game:

After the postal Mogry gives me a letter in Goblin Wall,
I get the error "Invalid write to 0x00000004, PC = 0x8001fd6c" once the screen wants to switch to the letter menu.
Every time I try to click it away, it pops up again. When I deactivate the error messages, I actually get to the letter menu, but when I close it again, Dolphin crashes.

I attached a save file right in front of Goblin Wall. I once assumed that the cheats I used were the problem, but I also get the error without the cheats. I tried to switch around the settings a bit, but this didn't help. It never did.

#15 Updated by Guitarkory1 about 3 years ago

@JMC4789: I tried turning off panic alerts like you suggested, it didn't help. the game still doesn't save if I go into the room that causes the invalid read. If I don't go into the room and trigger the invalid read, the game saves fine. its just this particular location that causes this bug.

#16 Updated by Guitarkory1 about 3 years ago

Just an update, The game works when using cached interpreter (it took a while but I tested it) it only doesn't work in JIT. I dont know if this information helps or not. But I tried changing alot of my settings to see if anything would make it work. The only thing that made the game work was cacheInterpreter.

#17 Updated by Guitarkory1 about 3 years ago

OK this is weird, saving works if I don't have graphics set to auto fractional (the invalid read disapears too). I guess that the issue is caused by auto fractional in the graphics tab. Sorry to spam so much, I had no Idea that fractional window size could cause issues like this.

#18 Updated by Korados about 3 years ago

What is auto fractional? How can I change this? I tried the Cached Interpreter but I still have the same problem.
What else did you change?

#19 Updated by Guitarkory1 about 3 years ago

Auto fractional is a setting in the graphics tab, located in the Internal Resolution tab. I still think its weird that the game works with this setting enabled on builds older than 540, but doesn't work on the new ones. but oh well. I will just have to remember not to use that setting with this game. Sorry it took so long to get back to you btw.

#20 Updated by Korados about 3 years ago

I think I found the auto fractional setting now. It's "EFBScale = x", isn't it? I tried to use several numbers but I still can't get past
the Invalid Read. I guess you must've done something else besides setting the graphics.

#21 Updated by Korados about 3 years ago

Ummm... I just switched around some settings and now the Invalid Read was gone and Dolphin didn't crash! But now I don't know what I did.

#22 Updated by Korados about 3 years ago

I'm sorry! I had the panic handlers off and thought it's gone. Well, that was stupid.

#23 Updated by Guitarkory1 about 3 years ago

I'm still talking about paper mario ttyd, I fixed it by switching auto fractional to something else. I havent gotten around to testing FFCC yet, (been busy with an OS assignment for class, making a screen saver for Linux Debian, still don't understand dolphins code at all though, or id try to fix the problem myself).

#24 Updated by JMC4789 about 3 years ago

Right click the game in the gamelist, click game properties, check - "Enable MMU" so that it is a checkmark.

#25 Updated by Guitarkory1 about 3 years ago

Already did that and tested paper mario ttyd (I have yet to test FFCC).
When using auto fractional + MMU, the game crashes with no panic alerts.
When not using auto fractional (mmu still enabled), no panic alerts, and no save corruption.
Without MMU enabled, as long as I don't use auto fractional, I can save fine, and don't receive any panic alerts. Auto fractional is not a issue with older builds such as build 530.

#26 Updated by JMC4789 about 3 years ago

Okay, well, I think it's time we remove fractional IR then.

#27 Updated by Guitarkory1 about 3 years ago

I think that's a good idea, auto fractional sometimes has unintended side effects with games, like pokemon XD for instance, I've never seen it break games like this though.

#28 Updated by JMC4789 about 3 years ago

It's a consequence of more accurate emulation in other areas, namely, the memory map.

It's unfortunate this happens, but, I've been looking for a good reason to kill it.

#29 Updated by JosJuice about 3 years ago

  • Assignee deleted (degasus)
  • Milestone set to Current

#30 Updated by JosJuice almost 3 years ago

  • Status changed from Questionable to Fixed
  • Fixed in set to 5.0-4788

Fractional IRs have been disabled for this game as of 5.0-4788.

Also available in: Atom PDF