Project

General

Profile

Emulator Issues #10179

Super Paper Mario Chapter 6 Crash on OpenGL backend

Added by ExE_Boss almost 3 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name

Super Paper Mario

Game ID

R8PE01

MD5 Hash

2740fc6cd66b1523cd358995f68c8840

What's the problem? Describe what went wrong.

On the OpenGL backend, Chapter 6-1 is unbeatable, because the game crashes during the cutscene after beating the guardian of the first gate.

What steps will reproduce the problem?

  1. Select the OpenGL backend
  2. Get to chapter 6-1
  3. Beat the guardian of the first gate
  4. When the King calls the Vassals and the gate opens, the game crashes

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

I have tested on the following versions:

  • 5.0-3183
  • 5.0-3202
  • 5.0-3239

What are your PC specifications?

Category Spec
OS Windows 10 64-bit
CPU Intel i7-3770K
GPU NVIDIA GeForce GTX 680
RAM 16 GB
GPU Driver Version 376.53

Is there any other relevant information?

The crash only happens on OpenGL
On DirectX 11, the game experiences a massive slowdown during the cutscene
On DirectX 12, the game runs fine during the cutscene
I haven't tested Vulkan as 376.53 doesn't support all features required by Dolphin (I would have to update to at least 377.14)


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 almost 3 years ago

Can you export a savefile right before the crash? Not a savestate. You should be able to right click the game in teh gamelist and hit export Wii save.

#2 Updated by ExE_Boss almost 3 years ago

Here's the save file (I wasn't sure if it was necessary), also there is another crash bug in 6-2, which I will create an issue for shortly.

#3 Updated by JMC4789 almost 3 years ago

  • Status changed from New to Questionable

Turn on Single Core, make sure EFB Copies to RAM is on, since this game uses that.

On my GTX 760, I had no issues there, no crash, and no slowdown (using single core even). I used your save and beat the second gate.

#4 Updated by ExE_Boss almost 3 years ago

I have EFB Copies to RAM on, but I didn't try Single Core.

The crash (a drop to 0 FPS with the sound breaking) only happened to me on OpenGL (the other backends were fine, that's how I managed to report #10180).

#5 Updated by JMC4789 over 1 year ago

  • Status changed from Questionable to Duplicate

I remembered this issue as soon as I loaded up your savefile.

#6 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF