Project

General

Profile

Emulator Issues #10201

Direct input force feedback causes emulator slowdown with some devices (Xbox One S controller, et al.)

Added by Lucario about 3 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Low
Assignee:
-
% Done:

0%

Operating system:
Windows
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Set Xbox One S controller to emulate GameCube controller port 1 and 2 under GameCube controller config, then do same to their rumble function

The result:
Bad lag in Super Mario Sunshine and Super Smash Bros. Melee, looks to be any GameCube games that use rumble will lag
Erratic rumble in Super Smash Bros. Brawl, looks to be any Wii games

If I use DualShock 3 (Nefarius' XInput Wrapper for DualShock 3 AKA to emulate Xbox 360 controller) to emulate port 1 and 2 of GCN ctrl, the result is no rumble in port 1.

Bisecting reveals that... (I've only bisect with Xbox One S controller)
No rumble until: 4.0-4523
Always lag: 4.0-4536 to 4.0-9228
Rumble lag since: 4.0-9230 until now, 5.0-3301

I'm running on Windows 10 and my DualShock 3 and Xbox One S controller are genuine, both are on bluetooth (2x bluetooth dongles, separate driver each).

I hope I'm stating things correctly because it's confusing. I think the ideal fix is to merge the rumble pattern into the most active one and send it to the same device as selected from multiple rumble configs. But more importantly the Xbox One S controller should not cause lag like DS3 (Xbox 360 controller?) did not.


Related issues

Is duplicate of Emulator - Emulator Issues #8465: Direct input force feedback causes emulator slowdown with some devicesFixed

History

#1 Updated by markwest76 about 3 years ago

I have an Xbox one S controller too, but to me the rumble bahaviour in Super Mario Sunshine seems pretty much the same as with the original Xbox controller (no lag)...

#2 Updated by markwest76 about 3 years ago

forgot to say that I use the controller usb wired

#3 Updated by Lucario about 3 years ago

No lag even though your controller is also emulating 2nd GCN ctrl's rumble?

I've tried wired, no dice, but maybe I need to restart my PC to confirm this?

#4 Updated by Lucario about 3 years ago

Okay! My memory is bit hazy to where I tested wired.

I tried Super Mario Sunshine wired, it rumbles erratically. I must have tested Brawl with it and thought the GCN games will stil lag, but turns out I'm wrong, the result is GCN games will do like Wii games when I'm on wired.

I think it's all "Dinput/0/Bluetooth XINPUT compatible input device" doing

#5 Updated by markwest76 about 3 years ago

I've just tried it with bluetooth connection and still no lag...

#6 Updated by JMC4789 about 3 years ago

Isn't this an issue with the xbox controller and how it polls?

#7 Updated by markwest76 about 3 years ago

I have only one controller, so maybe that lag is due to bluetooth not "keeping the pace" of two controllers connected?

#8 Updated by Lucario about 3 years ago

I can still reproduce this even my DS3 is not in use. By lag, the whole emulation lags, not rumble lag. It'll be more noticeable in rumble intensive GCN games.

I tried run two Dolphin instances, ran Super Mario Sunshine, Xbox's rumble became more active when each Mario are doing things differently, no whole emulation lag or erratic rumble.

Maybe you're not replicating this issue correctly? Only one controller, Xbox One S controller, to emulate two GCN controllers' rumble function, not two controllers to emulate one GCN controller, or maybe you're not actually on bluetooth when going "wireless". Do you happen to have dongle for Xbox controller?

My PC is i7-7700K with GTX 670. I'll try PCI bluetooth I have in my i7-2600K PC I haven't salvaged it to my i7-7700K PC. Though I really doubt my bluetooth is the problem. I'll try on different PC also, it's a i5-4690K PC with iGPU.

#9 Updated by Lucario about 3 years ago

Okay, I've added PCI bluetooth and the emulation got better, but is that really true? Is it normal that the bluetooth has the ability to slow down the emulation?

I forgot that my i5-4690K is running Windows 8.1, Xbox One S controller requires Windows 10.

I've noticed the title and all "rumble lag" mention are bit misleading, it's emulation that lags when Xbox One S controller is rumbling while it's emulating two GCN controllers' rumble function.

#10 Updated by Billiard26 over 1 year ago

  • Priority changed from Normal to Low
  • Status changed from New to Accepted
  • Subject changed from Weird rumble behavior with Xbox One S controller to Direct input force feedback causes emulator slowdown with some devices (Xbox One S controller, et al.)
  • Operating system Windows added
  • Operating system deleted (N/A)

#11 Updated by Billiard26 over 1 year ago

  • Status changed from Accepted to Duplicate

Duplicate of issue 8465.

#12 Updated by JosJuice over 1 year ago

  • Is duplicate of Emulator Issues #8465: Direct input force feedback causes emulator slowdown with some devices added

Also available in: Atom PDF