Project

General

Profile

Emulator Issues #10216

TTYD Pause Screen Vulkan Bug

Added by MetroPone almost 3 years ago. Updated almost 3 years ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Paper Mario: The Thousand Year Door

Game ID? (right click the game in the game list, properties, info tab)

G8ME01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

db9a997a617ee03bbc32336d6945ec02

What's the problem? Describe what went wrong.

When you pause the game, Mario and his partners are rendered on the pause screen. However, for some reason the Vulkan rendering engine renders it wrong, as if it got the layers mixed up.

What steps will reproduce the problem?

Pausing in the first two main areas of the game seems to do it, I'm very positive that other areas of the game are to be affected.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Dolphin 5.0 git release (compiled before 2 AM EST on April 17, 2017, the about screen doesn't specify a version besides "master")

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel(R) Core(TM) i7-3632QM CPU with Intel HD 4000 integrated graphics, running on Manjaro Linux 17.0.1 w/ Budgie Desktop

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

This install is basically a fresh install of Dolphin, with minimal changes done from a previous install of baisc 5.0, though I think the only option I changed was the speed of texture caching to be safe. 4 screenshots are provided in a zip file attached, showing Vulkan vs OpenGL.

Vulkan vs OpenGL.zip (859 KB) Vulkan vs OpenGL.zip This is a zip containing 4 files. The first two are Vulkan, and the other two are OpenGL. The first image shows right after opening a save, the second shows after a loading zone happens out of a pipe. MetroPone, 04/17/2017 06:12 AM

History

#1 Updated by Stenzek almost 3 years ago

Could possibly be a bug with the anv driver, I believe there is a similar issue in Metroid Prime.

Also available in: Atom PDF