Project

General

Profile

Emulator Issues #10225

Phantasy Star Online Episode I & II - FMVs don't play

Added by gourdcaptain over 2 years ago. Updated over 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?
Phantasy Star Online Episode I and II

Game ID? (right click the game in the game list, properties, info tab)

GPOE8P

What's the problem? Describe what went wrong.
FMV video will not show visuals if you wait on the title screen long enough to trigger. FPS show as 0 while the game plays the audio for the FMV, but not the FMV itself

What steps will reproduce the problem?

Leave the game running on the title screen long enough.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0r3406

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i7 6800k, AMD Radeon RX 460 (Mesa 17.0.4 drivers), Arch Linux 64-bit, and this was tested with the OpenGL, Vulkan, and Software Renderer backends and occured in each. This occurs on both Single Core and Dual Core.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Attached a log. Attaching a screenshot would be fairly useless as it would just be a black screen.

Dolphin Log - PSO 1&2 No FMV Video.txt (110 KB) Dolphin Log - PSO 1&2 No FMV Video.txt Dolphin logs collected during a boot and initial part of FMV playback. gourdcaptain, 04/22/2017 06:11 AM

History

#1 Updated by gourdcaptain over 2 years ago

...and I swore I put a name in for this issue. Whoops.

#2 Updated by pauldacheez over 2 years ago

  • Subject changed from [Short description of your bug here (~10 words)] to Phantasy Star Online Episode I & II - FMVs don't play

Have you tried setting External Frame Buffer to "Real"? A staggering portion of the GC/Wii library requires that for FMVs.

#3 Updated by gourdcaptain over 2 years ago

That appears to fix it. Should this be added to the default Gameini file for this game? There's some other FMVs if I remember right (it'd take an hour or two to reach when I think they are at least.)

#4 Updated by MayImilae over 2 years ago

  • Status changed from New to Invalid

Please read the wiki before posting to the issue tracker!

Also available in: Atom PDF