Project

General

Profile

Emulator Issues #10240

Star Wars: The Clone Wars can still crash between missions

Added by JMC4789 about 4 years ago. Updated almost 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Star Wars - The Clone Wars - GSXE64

What's the problem? Describe what went wrong.

When doing strings of missions, it appears that sometimes the game can hang on a loading screen. It has the same "Maxstreak" message on the hang that happens when you load the game with HLE audio.

What steps will reproduce the problem?

Unfortunately, I couldn't find a concrete way to reproduce this; it seems to happen between the fourth and fifth mission sometimes, and considering a mission can take between 10 and 15 minutes even if you don't die, that's a tough task.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0-3464

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i5-3570K @ 4.0 GHz, GTX 760, Windows 10

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Maxstreak message can easily be found by loading the game up with HLE audio enforced. That seems to have been caused by phire's coretiming fixes.

History

#1 Updated by JMC4789 about 4 years ago

It should be noted that this game changes the BATs between every mission, which I'd guess is a timing sensitive procedure.

#2 Updated by JosJuice almost 4 years ago

  • Is duplicate of Emulator Issues #10265: Star Wars: The Clone Wars hangs on loading screen with DSP-HLE and JIT Recompiler added

#3 Updated by JosJuice almost 4 years ago

  • Status changed from New to Duplicate

#4 Updated by JosJuice almost 4 years ago

  • Is duplicate of deleted (Emulator Issues #10265: Star Wars: The Clone Wars hangs on loading screen with DSP-HLE and JIT Recompiler)

#5 Updated by JosJuice almost 4 years ago

  • Status changed from Duplicate to New

#6 Updated by JMC4789 almost 3 years ago

  • Status changed from New to Invalid

Someone else can try to reproduce this in the future... I haven't seen it since. Maybe the game can rarely hang on console?

Also available in: Atom PDF