Project

General

Profile

Emulator Issues #10292

Emulated Wiimote - Shake not working in "Batman the Brave and the bold"

Added by Percybuttkins about 3 years ago. Updated over 1 year ago.

Status:
Fixed
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-9248

Description

Game Name?

Batman the Brave and the bold

Game ID? (right click the game in the game list, properties, info tab)

S3BEWR

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

c1b7e332e11f20fcee54ff1de0927c61

What's the problem? Describe what went wrong.

Works fine in 4.02, when going to 5.0 or higher shake is not working with emulated wiimote or nunchuck.

What steps will reproduce the problem?

After updating from 4.02 to 5.0 or higher, unable able to get it to recognize shake on emulated controller even when the indicator is red when button pushed showing that it has been triggered. I deleted all the configuration files and attempted to go back to 5.0 after getting to work with 4.02 but then continues not to work.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Does not work in nightly or stable 5.0 release. Works PERFECT in 4.02.

What are your PC specifications? (CPU, GPU, Operating System, more)

Windows 10, Intel core i-5-2500k, Nvidia Geforce 750ti.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]

History

#1 Updated by Percybuttkins about 3 years ago

I have figured out that when I use the default configuration it worked perfectly, but when I change the default ir settings, even when I manually specify the same output I used on the default settings it will not work until I use the button to reset the configuration. No matter the key assignment it Will not register for me.

#2 Updated by blubberdiblub about 3 years ago

As a workaround, try configuring some of the swing actions and alternate between pressing opposite ones to emulate shaking.

For instance configure N for left swing and M for right swing and then quickly alternate forth and back between N and M rhythmically and check if the game detects that as shaking.

#3 Updated by Percybuttkins about 3 years ago

OK, I tried swing which still appears to do nothing, but the forward, backward and shake commands will pull up the cursor momentarily before it dissappears again.

Relative input toggled doesn't seem to make a difference.

#4 Updated by Percybuttkins about 3 years ago

It does show the input as well when I am pushing the hot keys.... It's just not translating when the game is running

#5 Updated by iwubcode over 2 years ago

Please try https://github.com/dolphin-emu/dolphin/pull/6222 to see if it fixes your issue.

#6 Updated by Billiard26 over 1 year ago

  • Subject changed from Shake not working on emulated controller to Emulated Wiimote - Shake not working in "Batman the Brave and the bold"

#7 Updated by Billiard26 over 1 year ago

  • Assignee set to Billiard26
  • Status changed from New to Fix pending

Fix in PR.

#8 Updated by Billiard26 over 1 year ago

  • Status changed from Fix pending to Fixed

#9 Updated by JosJuice over 1 year ago

  • Fixed in set to 5.0-9248

Also available in: Atom PDF