Project

General

Profile

Emulator Issues #10326

[Vulkan]Failed to allocate streaming buffers

Added by Sunderland93 almost 3 years ago. Updated almost 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Silent Hill Shattered Memories

Game ID? (right click the game in the game list, properties, info tab)

SHLPA4

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

d088e9c8445121917e922d0027d6a160

What's the problem? Describe what went wrong.

When I running game with Vulkan backend, game (sometimes) crashed with error "Line: 491
File: /usr/src/packages/BUILD/Source/Core/VideoBackends/Vulkan/CommandBufferManager.cpp"

What steps will reproduce the problem?

1) Build and run Dolphin master
2) Enable Vulkan backend
3) Run Silent Hill Shattered Memories with double click from gamelist

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Dolphin from git master branch

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i3-550, Nvidia GTX 760 2 GB, Debian GNU/Linux 9, Nvidia driver 375.66, KDE 5 desktop environment.

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]

Screenshot_20170610_220049.png (384 KB) Screenshot_20170610_220049.png Sunderland93, 06/10/2017 01:01 PM
Screenshot_20170610_220058.png (398 KB) Screenshot_20170610_220058.png Sunderland93, 06/10/2017 01:01 PM
Screenshot_20170610_220104.png (405 KB) Screenshot_20170610_220104.png Sunderland93, 06/10/2017 01:01 PM
6119
6120
6121

History

#2 Updated by ThE_MarD almost 3 years ago

Heyyo, the issue is your graphics driver. Linux nVidia driver v381.26.03 is the first driver to receive Vulkan API support. Tbh I haven't used Debian so I'm unsure what the process is for Debian but you might be able to download the latest drivers from geforce.com and do that .run method :\

#3 Updated by blubberdiblub almost 3 years ago

You shouldn't use the binary blob on Debian (or Ubuntu, for that matter), as it will install files that may be hard to get rid of later (if you want to undo it) and it may mess with system-installed files.

Better wait for a newer packaged version.

If you do use the official installer nonetheless, the nvidia-installer-cleanup package might help you clean up the mess if you need to undo it.

#4 Updated by Stenzek almost 3 years ago

  • Status changed from New to Invalid

Closed as it is supposedly a driver/system issue. Please update if the issue still persists on a fully updated driver.

Also available in: Atom PDF