Project

General

Profile

Emulator Issues #10331

Super Smash Bros Melee Music cuts shortly after loading (dev versions only)

Added by sweg almost 3 years ago. Updated almost 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Smash Bros Melee

Game ID? (right click the game in the game list, properties, info tab)

GALE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

0e63d4223b01d9aba596259dc155a174

What's the problem? Describe what went wrong.

It appears the problem that Melee in Dolphin Emulator had in the past with music cutting out shortly after being loaded has returned in the dev versions of Dolphin Emulator (also happens with the beginning cutscene audio).

What steps will reproduce the problem?

If you have a 64 bit PC, download one of the latest dev versions of Dolphin Emulator

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Dolphin 5.0-4305, did not test using older versions of Dolphin

What are your PC specifications? (CPU, GPU, Operating System, more)

Processor: AMD Athlon(tm) 64 X2 Dual Core Processor 3800+ 2.00 GHz
RAM: 4.00 GB
Operating System: Windows 7 Home Premium (64-bit)
Graphics Card: Nvidia Geforce GT 620

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

Might wanna check any past dev versions that messed with audio after stable 5.0 release

History

#1 Updated by sweg almost 3 years ago

for Reproducing, get one of the latest dev versions of Dolphin, then get the Super Smash Bros Melee ISO file to test out with

#2 Updated by blubberdiblub almost 3 years ago

Approximately how many seconds is "shortly after being loaded"?

What is your audio configuration?
Also, do you use any other (non-audio) non-default settings that might affect the emulation?

I can't reproduce the problem on my system, no matter how hard I try. (I tried both Linux and Windows, all available audio backends, HLE, LLE recompiler, LLE interpreter, Dolby decoder, all work fine here.) I can play the whole intro without music cut-outs. Same for the stages.

However, I have different system specs here. (Intel CPU for instance.)

#3 Updated by JMC4789 almost 3 years ago

Do you have fast disc speed enabled? If so, turn it off. That's a cause for the audio cutting out in Melee.

#4 Updated by sweg almost 3 years ago

blubberdiblub wrote:

Approximately how many seconds is "shortly after being loaded"?

What is your audio configuration?
Also, do you use any other (non-audio) non-default settings that might affect the emulation?

I can't reproduce the problem on my system, no matter how hard I try. (I tried both Linux and Windows, all available audio backends, HLE, LLE recompiler, LLE interpreter, Dolby decoder, all work fine here.) I can play the whole intro without music cut-outs. Same for the stages.

However, I have different system specs here. (Intel CPU for instance.)

It's around 1-3 seconds after depending on what music it is (Beginning Intro is about 0.7 seconds, Main Menu is about 2, in-game music would be 2.5 for me. I use the HLE audio, though I tested with normal LLE and it didn't help. Main Menu Music and in-game music (as well as single-player stage complete theme) will randomly cut out with 1-3 seconds after loading.

As for potential non-audio non-default settings, it might be due to how I changed the ISO Core Properties (Disabled most except Enable Dual Core, Speed up Disc Transfer, and DSP HLE emulation), and how I'm using the basic 60Fps patch (not the smoother one or 120 FPS one).

#5 Updated by Helios almost 3 years ago

Like JMC said, turn off Speed up Disc Transfer.

#6 Updated by sweg almost 3 years ago

Helios wrote:

Like JMC said, turn off Speed up Disc Transfer.
It seems to have worked, thank you for that. Looks like if Speed Up Disc Transfer is checkmarked, and not either unchecked or a Blue Square, the bug happens.

#7 Updated by Fog almost 3 years ago

  • Status changed from New to Invalid

Also available in: Atom PDF