Project

General

Profile

Emulator Issues #10338

Call of Duty: Multiplayer Freezes Mega Issue

Added by counter185 over 1 year ago. Updated 10 months ago.

Status:
Accepted
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Call of Duty: Black Ops (the German version, but the same happens in every other version of the game)

Game ID? (right click the game in the game list, properties, info tab)

SC7D52

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

3cf5e6c1c5ed37956d9391c85530bff2

What's the problem? Describe what went wrong.
Everything is in the next section

What steps will reproduce the problem?
1. Start up the game
2. Go to either Multiplayer or Zombies
3. If in multiplayer menu the game will either crash or freeze and slow down to 0 fps
4. If in zombies menu the game will either crash or freeze and slow down to 0 fps upon selecting either Nintendo Wi-Fi Connection or Singleplayer

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?
Dolphin Master 5.0-4337 and earlier 4300 versions
Dolphin 4.0 (game doesn't work at all, just crashes the emulator)
Dolphin 4.0-691 wiispeak (same as 4.0)

What are your PC specifications? (CPU, GPU, Operating System, more)
Windows 8.1 Pro x64
Radeon HD 5850
Intel Core i5-6500
Dualshock 4 controller
msi Z170A Gaming M3 motherboard
16 GB RAM DDR4

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

https://drive.google.com/open?id=0B42b8cyn1f1_NkxUMmY5aUpPTlk - video of freeze and fps drop, crash with a real time log


Related issues

Has duplicate Emulator - Emulator Issues #9553: Call Of Duty Black Ops And Modern Warfare 3 FreezeDuplicate

Has duplicate Emulator - Emulator Issues #8785: Call of Duty Black ops Multiplayer freezesDuplicate

Has duplicate Emulator - Emulator Issues #6819: Call of Duty Series Wi-Fi doesn't work at allDuplicate

History

#1 Updated by blubberdiblub over 1 year ago

Does it work if you uncheck "Store EFB Copies to Texture Only" in Graphics Configuration / Hacks?

#2 Updated by counter185 over 1 year ago

blubberdiblub wrote:

Does it work if you uncheck "Store EFB Copies to Texture Only" in Graphics Configuration / Hacks?

Unchecking that doesn't change anything

#3 Updated by JMC4789 over 1 year ago

This is likely an IOS-HLE issue, so, I don't think graphical settings matter much.

#4 Updated by JMC4789 over 1 year ago

#5 Updated by JMC4789 over 1 year ago

#6 Updated by JMC4789 over 1 year ago

  • Subject changed from Black Ops: freeze on launching multiplayer, starting zombies and connecting to wfc to Call of Duty: Multiplayer Freezes Mega Issue
  • Status changed from New to Accepted

Hijacking this issue - it seems almost all the Wii Call of Dutys share these freezes

#7 Updated by JMC4789 over 1 year ago

#8 Updated by leoetlino 10 months ago

The game is stuck in a loop "wait[ing for] start server".

45:05:730 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 8046e210->8032e940| pre frame
45:05:730 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 8046c890->8046e21c| Com_EventLoop
45:05:731 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 8038bb50->8038bb34| update sound
45:05:731 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 805fb5d8->805fb5d4| dev perf counters
45:05:731 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804e1810->804bf648| menu paint screen
45:05:731 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804e1520->804e1504| menu paint internal
45:05:732 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804e187c->804bf7cc| menu paint full
45:05:732 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804e1520->804e1504| menu paint internal
45:05:736 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804a7264->804a7338| wait start server
45:05:749 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804a7264->804a7338| wait start server
45:05:764 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 8046e4a8->805a8568| Com_Frame
45:05:764 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 8046c890->8046df74| Com_EventLoop
45:05:764 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 8046e210->8032e940| pre frame
45:05:768 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804a7264->804a7338| wait start server
45:05:796 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804a7264->804a7338| wait start server
45:05:797 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804a7264->804a7338| wait start server
45:05:809 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804a7264->804a7338| wait start server
45:05:824 Core/HLE/HLE_OS.cpp:84 N[OSREPORT]: 804a7264->804a7338| wait start server
...

#9 Updated by leoetlino 10 months ago

35:59:378 Core/HLE/HLE_OS.cpp:48 N[OSREPORT]: [bdLogMessage] bdAuthService.cpp:1219 info/auth service [handleReply]: Task completed successfully
35:59:381 Core/HLE/HLE_OS.cpp:48 N[OSREPORT]: [bdLogMessage] bdAuthService.cpp:243 info/auth service [getStatus]: Closing AuthService connection due to reply. Status changed to BD_READY
...
35:59:511 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 805a8568->805a8580| GameMain
35:59:512 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 8046e4a8->805a8568| Com_Frame
35:59:512 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 8046c890->8046df74| Com_EventLoop
35:59:512 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 8046e210->8032e940| pre frame
35:59:520 Core/HLE/HLE_OS.cpp:48 N[OSREPORT]: [bdLogMessage] bdLobbyService.cpp:882 info/lobby service [onConnect]: Connected to MatchMaking Service.
35:59:568 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 804a7264->804a7338| wait start server
35:59:570 Core/HLE/HLE_OS.cpp:48 N[OSREPORT]: [bdLogMessage] bdBandwidthTest.cpp:47 err/bdBandwidthTestClient [init]: Bandwidth testing may freeze Demonware code on the Wii platform!
35:59:571 Core/HLE/HLE_OS.cpp:48 N[OSREPORT]: [bdLogMessage] bdBandwidthTest.cpp:70 info/bdBandwidthTestClient [init]: Initialised client.
35:59:575 Core/HLE/HLE_OS.cpp:48 N[OSREPORT]: [bdLogMessage] bdBandwidthTest.cpp:147 info/bdBandwidthTestClient [start]: Started bandwidth test of type: 0.
35:59:582 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 8046487c->80464868| motd-english.txt
35:59:594 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 804a7264->804a7338| wait start server
35:59:598 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 804a7264->804a7338| wait start server
35:59:610 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 804a7264->804a7338| wait start server
35:59:611 Core/HLE/HLE_OS.cpp:104 N[OSREPORT]: 804a7264->804a7338| wait start server
...

Looks like "bandwidth testing" may be the issue here. It's explicitly mentioned in a log message and the game never finishes the test, so...

Also available in: Atom PDF