Project

General

Profile

Emulator Issues #10363

Paper Mario TTYD Partner overworld sprite flickering

Added by jonwolfe over 2 years ago. Updated over 2 years ago.

Status:
Questionable
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Paper Mario: The Thousand Year Door

Game ID?

G8ME01

MD5 Hash?

db9a997a617ee03bbc32336d6945ec02

What's the problem? Describe what went wrong.

Partners are flickering between correct and incorrect sprite. Disable fast depth check will make the filtering stop, but both sprites will be displayed simultaneously

What steps will reproduce the problem?

Reveal the first crystal star on the treasure map

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

Dolphin 5.0-4487 and an earlier on I don't have the number of

What are your PC specifications?

See attachment: JONWOLFE-DESKTO.txt

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

  • Screenshot attached, not sure how to give you logs
  • Seems to be similar to issue #9598
  • all back-ends present the same problem in exactly the same manner
JONWOLFE-DESKTO.txt (190 KB) JONWOLFE-DESKTO.txt PC specs jonwolfe, 06/26/2017 01:24 AM
G8ME01-1.png (984 KB) G8ME01-1.png Screenshot of issue jonwolfe, 06/26/2017 01:24 AM
01-G8ME-mariost_save_file.gci (136 KB) 01-G8ME-mariost_save_file.gci jonwolfe, 06/28/2017 01:06 AM
6161

History

#1 Updated by JMC4789 over 2 years ago

This could potentially be a driver bug. I'd definitely prefer if you could test Dolphin's 5.0 release and Dolphin's 4.0 release to see if it happens in both of those. From there, that may give enough information to try and narrow down if the bug is in Dolphin or somewhere else.

#2 Updated by jonwolfe over 2 years ago

JMC4789 wrote:

This could potentially be a driver bug. I'd definitely prefer if you could test Dolphin's 5.0 release and Dolphin's 4.0 release to see if it happens in both of those. From there, that may give enough information to try and narrow down if the bug is in Dolphin or somewhere else.

Retested in 4.0.2 and 5.0.0. 4.0.2 did not produce the bug but 5.0.0 did.

#3 Updated by JMC4789 over 2 years ago

This probably means there's a bug in your driver... can you give a savefile near where you're at so maybe I can throw them at other people with different graphics cards.

#4 Updated by jonwolfe over 2 years ago

Sure, here's the GCI (attached)

#5 Updated by JMC4789 over 2 years ago

Are you by chance using a custom texture pack?

#6 Updated by jonwolfe over 2 years ago

Yep, but error occurs with and without.

#7 Updated by JMC4789 over 2 years ago

  • Status changed from New to Questionable

Could you please bisect the issue. Helios made an excellent bisect tool that should make this pretty easy for you to do.

https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds. Questionable marking will remain until the bisect is completed, as I haven't run into this yet...

Also available in: Atom PDF