Project

General

Profile

Emulator Issues #10365

PNG banners are gone from game list when loading games from cache

Added by JosJuice over 1 year ago. Updated 12 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-4478
Fixed in:

Description

Regression in https://github.com/dolphin-emu/dolphin/pull/5659/commits/f16599f4a842c51412a4d890cdaccf4f0b618872

Steps to reproduce:

  1. Put a DOL or ELF file in a directory that will be scanned by the game list.
  2. Put a PNG file named icon.png in the same directory as the DOL or ELF file. (It's also possible to give the PNG file the same name as the DOL or ELF file apart from the extension.)
  3. Launch DolphinWX. (This will add the file to the cache. The custom PNG banner will show up in the game list if the file wasn't already in the cache.)
  4. Launch DolphinWX again. The custom PNG banner won't show up the game list.

Expected behavior:

When a DOL or ELF file is cached, Dolphin loads the custom banner from the cache or the PNG file.

Actual behavior:

When a DOL or ELF file is cached, Dolphin doesn't load the custom banner at all.


Related issues

Is duplicate of Emulator - Emulator Issues #10938: Feature regression: Custom PNG banners Fixed

History

#1 Updated by JMC4789 over 1 year ago

  • Status changed from New to Accepted

#2 Updated by JosJuice 12 months ago

#3 Updated by JosJuice 12 months ago

  • Status changed from Accepted to Duplicate

Also available in: Atom PDF