Project

General

Profile

Emulator Issues #10366

Feature regression: Can't use PNG banners for volumes

Added by JosJuice over 1 year ago. Updated 12 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Feature request
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-4478
Fixed in:

Description

When the ability to use PNG banners was added to DolphinWX, it intentionally worked for both DOL/ELF files and for volumes. A removal of the ability to use PNG banners for volumes was included as part of https://github.com/dolphin-emu/dolphin/pull/5659/commits/f16599f4a842c51412a4d890cdaccf4f0b618872. It seems like it could've been an accident since there still is a comment in ISOFile.cpp saying that PNG banners can be used with volumes, but at the same time, supporting this does make the game list performance worse, so it could've been intentional...

I've marked this issue report as Current, not because I'm saying it has to be fixed before the next stable release no matter what, but because we should either fix it or make a proper decision to drop this feature. (That the removal was in a self-merged PR with no LGTMs that didn't point out the removal in any commit description or PR comment meant that there was essentially no input on whether the removal was fine.) So I'd like to do it this way: If others agree to drop this feature, close this issue. Otherwise, this issue remains open as a Current blocker.


Related issues

Is duplicate of Emulator - Emulator Issues #10938: Feature regression: Custom PNG banners Fixed

History

#1 Updated by Helios over 1 year ago

  • Status changed from New to Accepted

#2 Updated by JosJuice 12 months ago

#3 Updated by JosJuice 12 months ago

  • Status changed from Accepted to Duplicate

Also available in: Atom PDF