Project

General

Profile

Emulator Issues #10367

Arc Rise Fantasia - All Gecko Codes broken by 5.0-845

Added by JMC4789 over 4 years ago. Updated over 4 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Arc Rise Fantasia - RPJE7U

What's the problem? Describe what went wrong.

Dolphin's Gecko Code handling isn't that great, and instead of triggering based on a particular interrupt, it simply fires after an interval of time. Arc Rise Fantasia likely takes too long for a frame, causing the code handling to malfunction and crash the emulator. This is why users reported that speedup disc transfer rate + higher emulated CPU clocks repair the codes.

What steps will reproduce the problem?

Enable a code and hit a loading screen, you're very likely to crash.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0-845 to 5.0-4567 (latest of this post) are broken.
Prior to that it works.

According to the problem is unrelated to that change, and it just brought it to the forefront. Implementing better hooking modes will likely fix this issue. Along with Arc Rise Fantasia, Gecko Codes don't work in any Wiiware/VC games due to another bug.


Related issues

Is duplicate of Emulator - Emulator Issues #10456: Gecko Codes Causing Freezes or Malfunctioning Across Many TitlesInvalid

History

#1 Updated by Lettendo over 4 years ago

Also happens at Mario Party 4. The emulation hangs when the Nintendo logo appears. Why is issue not marked as "regression"?

#2 Updated by JMC4789 over 4 years ago

The bug is caused by a pre-existing condition - namely that our hooking method is based on amount of time rather than any of the real hooks. It's just bad luck that we managed to break a few more games due to an unrelated change in behavior.

#3 Updated by JMC4789 over 4 years ago

  • Status changed from New to Duplicate

Moving to a new issue

#4 Updated by JMC4789 over 4 years ago

  • Is duplicate of Emulator Issues #10456: Gecko Codes Causing Freezes or Malfunctioning Across Many Titles added

Also available in: Atom PDF