Project

General

Profile

Emulator Issues #10388

Screen stops updating on Vulcan before result screen with Store EFB Copies to Texture Only checked.

Added by Skywolf almost 3 years ago. Updated over 2 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-5150

Description

Game Name?

Super Smash Bros: Brawl

Game ID?

RSBE01

MD5 Hash?

d18726e6dfdc8bdbdad540b561051087

What's the problem? Describe what went wrong.

When using the Vulkan backend and you finish a match the screen stops updating and keeps hanging at the last frame before the result screen is supposed to show. The game doesn't freeze and you can still navigate the menus using the audio. But even starting a new match won't get the screen to update again. It keeps hanging like this until the emulation is restarted.

This only happens with Store EFB Copies to Texture Only checked. Unchecking this fixes the issue but no other backend needs this and neither is it overwritten by the .ini file.

What steps will reproduce the problem?

1: Make sure you have Vulcan set as the Backend.
2: Make sure Store EFB Copies to Texture Only is Checked
1: Start a match which has a results screen at the end (just a Brawl match will do).
2: End it somehow (Either reach the time limit, run out of stock or just quit from the pause menu).

Matches that go back to the character select screen like training mode aren't affected by this issue.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

5.0-4607

If someone can tell me which build first included the Vulkin backend I can try to figure out if this is a regression issue and if so which version introduced it.

What are your PC specifications? (CPU, GPU, Operating System, more)

i5-2500k@4.3Ghz
8GB 1600 ddr3 RAM
GTX 1060 6GB
Windows 7 Home Premium

History

#1 Updated by blubberdiblub almost 3 years ago

I can confirm this. (I have the PAL Version of the game.)

GTX 960 here.
Happens both under Windows 10 and Linux.

However, EFB To Texture enabled is insufficient for me to reproduce.
I also need to have SSAA enabled, otherwise it won't happen. (I haven't tried MSAA yet.)

#2 Updated by blubberdiblub almost 3 years ago

FWIW, the oldest build I can run the game with at all without crashing right at the start is 5.0-1174:
https://dolphin-emu.org/download/dev/4cf873ea7359ce2e523bff422cc8c6fc1e26beea/

And it still locks up at the results screen under the aforementioned conditions. So it doesn't appear like a regression.

#3 Updated by Skywolf almost 3 years ago

Just tested MSAA. Has the same result as using SSAA.

Interestingly enough it seems the game shows an EFB copy of the entire screen right before it shows the result screen (this can be seen when disabling Scaled EFB Copy and running the game at something higher than 1X IR). It's this image that creates the illusion the game hangs at the last frame. Oddly enough, using Wireframe rendering doesn't show anything being rendered behind it.

#4 Updated by JMC4789 over 2 years ago

  • Status changed from New to Accepted
  • Assignee set to Stenzek
  • Milestone set to Current

Confirmed as well

#5 Updated by JMC4789 over 2 years ago

  • Status changed from Accepted to Fix pending

#7 Updated by JMC4789 over 2 years ago

  • Status changed from Fix pending to Fixed

Also available in: Atom PDF