Project

General

Profile

Emulator Issues #10438

VULKAN: game Star Wars Rogue Squadron III: Rebel Strike crashes after the "disco intro"

Added by legluondunet about 3 years ago. Updated about 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Star Wars Rogue Squadron III: Rebel Strike

Game ID? (right click the game in the game list, properties, info tab)

GLRP64

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

417e4f8f8e967c069635002e687c79be

What's the problem? Describe what went wrong.

The game stop working after the "disco intro"

What steps will reproduce the problem?

gpu plugin: Vulkan, launch the game, wait for the "disco intro" to finish, game crashes with this message:

first error message:
GFX FIFO: Unknown Opcode (0x57 @ 0x7ff5b041c001, preprocess=false).
This means one of the following:
* The emulated GPU got desynced, disabling dual core can help
* Command stream corrupted by some spurious memory bug
* This really is an unknown opcode (unlikely)
* Some other sort of bug

Further errors will be sent to the Video Backend log and
Dolphin will now likely crash or hang. Enjoy.

second error message:
Illegal command 57
CPBase: 0x006be500
CPEnd: 0x006ce4e0
CPHiWatermark: 0x0000c000
CPLoWatermark: 0x00008000
CPReadWriteDistance: 0x000003e0
CPWritePointer: 0x006cb680
CPReadPointer: 0x006cb2a0
CPBreakpoint: 0x007f72a0
bFF_GPReadEnable: false
bFF_BPEnable: false
bFF_BPInt: false
bFF_Breakpoint: false
bFF_GPLinkEnable: true
bFF_HiWatermarkInt: true
bFF_LoWatermarkInt: false

Sometimes they is no error message, it just freezes on the Factor Logo.

Which versions of Dolphin did you test on? Does using an older version of Dolphin solve your issue? If yes, which versions of Dolphin used to work?

git 3 august 2017

What are your PC specifications? (CPU, GPU, Operating System, more)

Ubuntu 17.04 Zesty Zapus 64 bits - NVIDIA GeForce GTX 770 - official Ubuntu Nvidia drivers 375.66 - 1920x1080 - Processor Intel i5-3570 3,4 Ghz - 8 Go RAM

Is there any other relevant information? (e.g. logs, screenshots,
configuration files)

[Anything else here]

History

#1 Updated by JMC4789 about 3 years ago

This isn't a vulkan issue, our GPU timings just fail right now.

#2 Updated by JMC4789 about 2 years ago

  • Status changed from New to Duplicate

This issue isn't exactly wrong, but, considering what's actually going on it's misleading.

#3 Updated by JMC4789 about 2 years ago

#4 Updated by JMC4789 about 2 years ago

  • Status changed from Duplicate to Invalid

Marking Invalid instead of Duplicate since it's not just dualcore, but single core as well.

#5 Updated by JosJuice 6 months ago

Also available in: Atom PDF