Project

General

Profile

Emulator Issues #10461

4GB or larger SD cards cause "Receiving Vault Data..." message to display before title screen in SSBB

Added by ryanebola16 about 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Smash Bros. Brawl

Game ID? (right click the game in the game list, properties, info tab)

RSBE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

Edited ISO, works fine on both Dolphin and real Wii

What's the problem? Describe what went wrong.

4GB or larger SD cards cause a "Receiving Vault Data..." message to display before the title screen. Though this only takes a small amount of time it can add up when you need to test code on Dolphin. This message does not appear on a real Wii.

What steps will reproduce the problem?

  1. Set Brawl as default ISO
  2. Download the "SDHC Nov14.rar" from here http://forums.kc-mm.com/Gallery/BrawlView.php?Number=213356
  3. Create a 4GB sd.raw (using the batch file here: http://forums.kc-mm.com/index.php?topic=74757.0 or mksdcard) and place it in the appropriate location
  4. Add the extracted contents of "SDHC Nov14.rar" to the 4GB sd.raw and close it
  5. Start the game using Gecko OS
  6. In Gecko OS config option, set "Gecko Hook Type" to "AXNextFrame"
  7. Save Config
  8. Return to menu
  9. Launch Game
  10. Observe "Receiving Vault Data..." message

If you want to see the problem not occur on a 2GB sd.raw:

  1. Set Brawl as the default ISO
  2. Delete ...SDHC Nov 14\Private\Wii\App\RSBE\pf\Fighter to reduce the size of the mod to under 2GB
  3. Create a 2GB sd.raw (using the batch file here: http://forums.kc-mm.com/index.php?topic=74757.0 or mksdcard) and place it in the appropriate location
  4. Add the extracted contents of "SDHC Nov14.rar" to the 2GB sd.raw and close it
  5. Start the game using Gecko OS
  6. In Gecko OS config option, set "Gecko Hook Type" to "AXNextFrame"
  7. Save Config
  8. Return to menu
  9. Launch Game
  10. Observe no "Receiving Vault Data..." message

It is important to make sure the bug hasn't already been fixed. Please tell us what the latest version you've verified the bug on.

5.0-5132. This issue has likely always existed in Dolphin. The SDHC compatibility modifications did not alter this issue.

What are your PC specifications? (CPU, GPU, Operating System, more)

Win 10 Pro x64
Intel Core i7-4702MQ CPU @2.20GHz
GeForce GT 750M
GeForce Game Ready Driver 384.94

1SSBB Gecko.elf (494 KB) 1SSBB Gecko.elf Gecko OS ryanebola16, 08/13/2017 08:23 PM
Log 2GB SD.txt (156 KB) Log 2GB SD.txt Did not reproduce issue ryanebola16, 08/14/2017 05:20 PM
Log 4GB SD.txt (156 KB) Log 4GB SD.txt Reproduced issue ryanebola16, 08/14/2017 05:21 PM

Related issues

Is duplicate of Emulator - Emulator Issues #10514: SDHC read times are very slowAccepted

History

#1 Updated by JMC4789 about 2 years ago

Do we know what causes the receiving vault data to show up on console? I've seen it a lot myself.

#2 Updated by ryanebola16 about 2 years ago

I think it appears when the game is downloading data from Smash Service or receiving something sent by a friend.

#3 Updated by JMC4789 about 2 years ago

Are there any log differences? We need to figure out why it's doing this...

#4 Updated by ryanebola16 about 2 years ago

I recorded two logs but nothing notable stood out to me.

I also tried interpreter and starting without game save data but that didn't alter the problem.

#5 Updated by JMC4789 about 2 years ago

Using cheatcodes can cause the vault data thing to show up, it's likely unrelated to the SD card handling code but we're hitting something (maybe a different path due to bad cheatcode support in Dolphin?) that causes it to want to reload vault data.

FWIW, I had this happen on wii too when loading Brawl-

#6 Updated by ryanebola16 about 2 years ago

If I use the same 2GB worth of data on the following setups, the results are:
Real Wii: No "Receiving Vault Data..." message
Dolphin with 2GB sd.raw: No "Receiving Vault Data..." message
Dolphin with 4GB sd.raw: "Receiving Vault Data..." message

If the only thing that causes the message to appear is using a 4GB sd.raw, this is likely a Dolphin problem.

#7 Updated by TheGag96 about 2 years ago

I noticed this message too immediately when using SDHC, and I always figured that this related to the greater problem of SDHC's file read (and probably write, though I've never tested) speeds being very slow. When trying out Legacy XP, for example, the music at the character selection screen that loads continuously off of the SD will often stop playing because it can't read fast enough. My guess was that Brawl itself will show "Receiving vault data" after a set amount of time if it's taking longer to read than usual, which is why you'd see it now and not before.

#8 Updated by JMC4789 about 2 years ago

See, I didn't see this update. Can you make a separate issue spotlighting how slow our SDHC speeds are with a comparison to something on console perhaps? I'm very interested in fixing it if possible.

#9 Updated by ryanebola16 almost 2 years ago

I am no longer able to reproduce this issue on 5.0-5132 or 5.0-5934 using my primary Dolphin directory.

I made a portable.txt file to re-test this issue in 5.0-5132 and 5.0-5934 and I reproduced the issue.
I needed to install IOS36-64-v3608.wad to run Gecko OS. (See #10662 and #10663)

For whatever reason, replacing either "\Wii\shared2\sys" or "\Wii\shared2\wc24" with folders from my primary Dolphin directory in the problematic portable builds prevents this issue from occurring. I'm fairly certain that I didn't dump the files that prevent this issue but I'm not positive. If these files don't contain any sensitive information I could upload them.

#10 Updated by leoetlino over 1 year ago

  • Status changed from New to Duplicate

This is very likely to be caused by our IOS timings being completely wrong (in particular SDIO), so I'm marking this as a duplicate of #10514.

#11 Updated by leoetlino over 1 year ago

Also available in: Atom PDF