Project

General

Profile

Emulator Issues #10467

NHL Slapshot in-game graphics issues

Added by rbuckla1 about 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
Yes
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
5.0-4703
Fixed in:

Description

Game Name?

NHL Slapshot

Game ID? (right click the game in the game list, properties, info tab)

SHYE69

In recent dev builds, the game has become unplayable with the distortion shown in the attached screen capture... cutscreens and game menus work properly.

I have tried dev build to 5169 and the distortion still exists.

Game is playable in the Stable r5 release albeit with a vertical black line present in the game & cut screens.

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[Put MD5 Hash here]

What's the problem? Describe what went wrong.

[Description here]

What steps will reproduce the problem?

[Reproduction steps here]

It is important to make sure the bug hasn't already been fixed. Please tell us what the latest version you've verified the bug on.

[Version number here]

Is the issue present in the latest stable version?

[Yes/No and version number here]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

Capture.PNG (448 KB) Capture.PNG Gameplay screenshot rbuckla1, 08/16/2017 10:31 AM
NHLSlapRegression.7z (1.65 MB) NHLSlapRegression.7z JMC4789, 08/16/2017 11:20 AM
6254

Related issues

Is duplicate of Emulator - Emulator Issues #11164: TMEM emulation regressionsAccepted

History

#1 Updated by JMC4789 about 2 years ago

oh shit when did this happen

#2 Updated by JMC4789 about 2 years ago

Since you didn't actually do the important steps of the issue template, I'll have to do the work to actually bisect it.

#3 Updated by rbuckla1 about 2 years ago

Game tested on multiple platforms:

Platform 1:

Core i7 3537U w HD4000 graphics, 16GB RAM - Direct3D - Game launches with issue; OpenGL: Game hangs immediately when launched

Platform 2:

MacBook Pro Late 2011 w/ATI 6750M graphics, 16GB RAM - Same results as above

#4 Updated by JMC4789 about 2 years ago

OpenGL launches the game fine, that's likely something on your end. I'm currently bisecting what build caused the distortion.

#5 Updated by rbuckla1 about 2 years ago

Sorry... I missed those items...can I edit the template somehow?

#6 Updated by JMC4789 about 2 years ago

No worries. I'm looking into it now. I have the game on hand and it's pretty fast to reproduce.

#7 Updated by JMC4789 about 2 years ago

It seems to be very, very recent though, so, shouldn't take me too long to find who did it.

#8 Updated by rbuckla1 about 2 years ago

Could be crappy old Vid cards I have on-hand at the moment... I will try something a bit more modern to confirm OpenGL results...

Thanks again and sorry for the missing data... my 1st dolphin bug report! :)

#9 Updated by JMC4789 about 2 years ago

It's a good report because it's definitely a valid bug :)

#10 Updated by JMC4789 about 2 years ago

The game kinda works in the Software Renderer. Kinda.

The regression is between 5.0-4645 and 5.0-4839. Will narrow it down to the problem build :)

#11 Updated by JMC4789 about 2 years ago

  • Regression start set to 5

#12 Updated by JMC4789 about 2 years ago

  • Status changed from New to Accepted
  • Assignee set to mimimi
  • Milestone set to Current
  • Regression changed from No to Yes
  • Regression start changed from 5 to 5.0-4703

#13 Updated by rbuckla1 about 2 years ago

Cool!

BTW I confirmed the ability to launch via OpenGL with a Skull Canyon NUC running IRIS Pro 580 graphics...

#14 Updated by JMC4789 about 2 years ago

Fifolog uploaded

#15 Updated by JMC4789 about 2 years ago

uploaded the fifolog to fifoci as well so when it's fixed, you'll know.

#16 Updated by rbuckla1 about 2 years ago

Excellent... thank you for the quick and helpful response!

#17 Updated by JMC4789 over 1 year ago

  • Status changed from Accepted to Duplicate

There are more games affected than just this one. Made an issue to pile into.

#18 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF