Project

General

Profile

Emulator Issues #1047

mii's don't look right

Added by kevinx0404 almost 11 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What steps will reproduce the problem?
1. Play a game like wii sports
2. In the duck hunt game, the mii character is just a blue tinge
3. It was fine In oder versions

What is the expected output? What do you see instead?
A mii face. Instead, I see blue

What version of the product are you using? On what operating system?
I'm on xp and I think that 3545 broke it.

History

#1 Updated by kevinx0404 almost 11 years ago

Sorry, it should've been wii play. Not wii sports.

#2 Updated by marcus almost 11 years ago

  • Status changed from New to Questionable

Correctly if I'm wrong, but AFAIK Miis never worked right.

#3 Updated by kevinx0404 almost 11 years ago

No, in previous revisions, the mii face was showing on the target board thing. Now
all I get is a blue/purple blob.

#4 Updated by daws72 almost 11 years ago

I never have any Mii face working in Wii Sports, Wii Play and Mii channel too.
No eyes, no mouth, plus some missing face polys. To me looks like a Z-buffer problem.
IMHO. None of the actual projection "hacks" fix the issue.

#5 Updated by kevinx0404 almost 11 years ago

Yeah, I could see the basic outline of the face and some features, but now it's just
a blue blob.

#6 Updated by ChaosCode almost 11 years ago

this issues title is to general. can someone change it to mii's don't look right.

#7 Updated by kevinx0404 almost 11 years ago

too bad you can't edit titles. Should I open a new issue?

#9 Updated by XTra.KrazzY almost 11 years ago

  • Status changed from Questionable to Won't fix

It's because you don't have the Mii file in your user directory, nor the Mii Channel.

#10 Updated by kevinx0404 almost 11 years ago

but then why did older versions have it working?

#11 Updated by XTra.KrazzY almost 11 years ago

  • Status changed from Won't fix to Accepted

just let me know which revision broke it...

#12 Updated by daws72 almost 11 years ago

Mii channel has problem too. No eyes and mouth, also some face are not displayed.

#13 Updated by kevinx0404 almost 11 years ago

I'm pretty sure that 3545 broke it. I tested 3540 and 3552. Posted screenshots in a
second.

#14 Updated by kevinx0404 almost 11 years ago

here is 3540

#15 Updated by kevinx0404 almost 11 years ago

here is 3552

#16 Updated by XTra.KrazzY almost 11 years ago

Maybe that's the same reason Mario has no eyes in SMG!

#17 Updated by kevinx0404 almost 11 years ago

revert?

#18 Updated by sl1nk3.s almost 11 years ago

afaik, Mario never had eyes on Dolphin even on way odler revs :(

#19 Updated by daws72 over 10 years ago

Fixed in r4532 great work!

#20 Updated by Autoran1 over 10 years ago

look near perfect on latest revs

#21 Updated by Anonymous over 10 years ago

  • Status changed from Accepted to Fixed

#22 Updated by daws72 over 10 years ago

Well, indeed is not completly fixed.
When you run a game with Mii like Wii Sports, you got perfectly looking mii's, but if
you strech or change the window size, like going full screen etc. the Mii's suddenly
loose their face attributes.

#23 Updated by fjavier2k over 10 years ago

Also, it seems that there are problems when you have too many miis saved (I have about
25) disappearing facial attributes of some of them. When they try to smile or close
their eyes, or express other emotions, their eyes and mouth suddenly disappear. You can
clearly see this problem with the "Wii music" game.

#24 Updated by daws72 over 10 years ago

Issue present also in later revs. >r4900. Please reopen the issue.
Well something still wrong in Mii's face rendering.
At start (Wii Sports / Wii Sport resort) the Mii's face are looking ok, but if you
resize the window (ie: going full screen etc.) or if you see many Mii's (ie: when
skydiving in the WiiSports Resort intro) the Mii face are not showing again, only
plain face, no eyes, no nose, no mouth ecc..
Need to check r4532.

#25 Updated by daws72 over 10 years ago

OpenGL /DX9 JIT/JITIL give same results.

#26 Updated by Anonymous over 10 years ago

Yup, got broken again recently...

#27 Updated by tsubum over 9 years ago

still broken on latest revision

Also available in: Atom PDF