Project

General

Profile

Emulator Issues #10475

Soulcalibur II needs EFB to RAM for lens flares

Added by xerxes about 2 years ago. Updated over 1 year ago.

Status:
Invalid
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Soulcalibur II

Game ID?

GRSEAF

MD5 Hash?

0c8ec93f3f4f4e00d5a46443225c169c

What's the problem? Describe what went wrong.

Lens flare effects when looking at the sun don't display with Store EFB Copies to Texture Only enabled. This can be seen very clearly in the Xiwei Siege Ruins stage for example (the fourth one up from random select when choosing a stage). This was found by hyperspeedgx on the Hybrid XFB pull request, and I tried it myself in both OGL and D3D11 to confirm.

What steps will reproduce the problem?

1) Start the game on practice mode, select any characters
2) Press up four times on stage select to get Xiwei Siege Ruins
3) Sidewalk up or down to spin the camera around so that the sun is visible

It is important to make sure the bug hasn't already been fixed. Please tell us what the latest version you've verified the bug on.

5.0-5209

Is the issue present in the latest stable version?

Yes

If the issue isn't present in the latest stable version, which is the first broken version?

I don't think it ever worked but I haven't tested any 4.0 builds again to see. I just think nobody noticed the effect was missing, like how the missing fades for this game also went undetected for a long time.

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

I'm attaching a fifolog which shows the lens flare, but if I record the fifolog with EFB to Texture and no lens flare, then uncheck it, the lens flare won't show up. The opposite is also true, so for me the lens flare is displaying in this log even with EFB to Texture. I don't know if that's normal or not?

What are your PC specifications?

Intel Core i3-3220 @ 3.3Ghz, NVIDIA GeForce GTX 1060 6GB, Windows 10

sc2-flare2.7z (2.13 MB) sc2-flare2.7z xerxes, 08/18/2017 12:24 PM

History

#1 Updated by JMC4789 about 2 years ago

  • Status changed from New to Questionable

We usually don't force enable EFB Copies to RAM for non-essential effects.

Users can enable/disable it on their own. The best thing to do is just document it on the wiki for people to know how to fix it.

#2 Updated by JosJuice about 2 years ago

  • Assignee set to JosJuice

I'll put a note about it in the game INI, without actually forcing it off. But yeah, I suggest documenting it on the wiki.

#3 Updated by xerxes about 2 years ago

Way ahead of you guys, I already did. It's standard to submit bug reports for any problem on there though, there's even functionality on the wiki to find issues without reports, so I thought it was a good idea to make one.

#4 Updated by JosJuice over 1 year ago

  • Status changed from Questionable to Invalid

Game INIs no longer support notes.

Also available in: Atom PDF