Project

General

Profile

Emulator Issues #10476

Paper Mario: The Thousand Year Door Crashes after Bowser and Lord Crump get blown up by the superbombomb

Added by mlgsupersanik almost 3 years ago. Updated about 2 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Paper Mario: The Thousand Year Door

Game ID? (right click the game in the game list, properties, info tab)

G8ME01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

d13426a926055be11a8330b27fe231ea

What's the problem? Describe what went wrong.

After Bowser and Lord Crump get blown up by the superbombomb the game saves and then crashes.

What steps will reproduce the problem?

just play through the game as usual and it will crash.

It is important to make sure the bug hasn't already been fixed. Please tell us what the latest version you've verified the bug on.

5.0

Is the issue present in the latest stable version?

Yes

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel Core i3-4030U - HD graphics 4400 - Windows 10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

No

MemoryCardA.USA.zip (32.7 KB) MemoryCardA.USA.zip mlgsupersanik, 08/18/2017 02:34 PM
MemoryCardA.USA.zip (24.3 KB) MemoryCardA.USA.zip mlgsupersanik, 08/24/2017 06:55 PM

History

#1 Updated by JosJuice almost 3 years ago

Please test this in the latest development version of Dolphin.

In case it doesn't work there either, please provide more details about when in the game it happens. Is it five minutes after starting the game, or do we have to play through several chapters to get there? If it's not right at the beginning, please provide a save file from as soon as possible before it happens.

#2 Updated by mlgsupersanik almost 3 years ago

JosJuice wrote:

Please test this in the latest development version of Dolphin.

In case it doesn't work there either, please provide more details about when in the game it happens. Is it five minutes after starting the game, or do we have to play through several chapters to get there? If it's not right at the beginning, please provide a save file from as soon as possible before it happens.

It also doesn't work in the latest version.
It only happens when Bowser and Lord Crump get blown up by the superbombomb and it asks you to save then it crashes.
also i can't give you the save file because its 16 MB big.

#3 Updated by JosJuice almost 3 years ago

Just to confirm, you mean 5.0-5209 by "the latest version", right?

I have no idea when in the game Bowser and Lord Crump get blown up by the superbombomb. Please at least tell us what chapter that's in, so that we don't have to spend potentially tens of hours playing the game just to find out how to reproduce the issue. (Assuming the save file can't get uploaded, that is.)

Try putting the save file in a zip file so that it'll be smaller.

#4 Updated by mlgsupersanik almost 3 years ago

JosJuice wrote:

Just to confirm, you mean 5.0-5209 by "the latest version", right?

I have no idea when in the game Bowser and Lord Crump get blown up by the superbombomb. Please at least tell us what chapter that's in, so that we don't have to spend potentially tens of hours playing the game just to find out how to reproduce the issue. (Assuming the save file can't get uploaded, that is.)

Try putting the save file in a zip file so that it'll be smaller.

Yes i tested it with 5.0-5209 and it didn't work.
The place where the game crashes is right after chapter 5.

#5 Updated by JMC4789 almost 3 years ago

  • Assignee set to JMC4789

I'd really rather just have a gci, but, I can test from the blob memcard

#6 Updated by JMC4789 almost 3 years ago

  • Status changed from New to Questionable
  • Assignee deleted (JMC4789)

I can't load your rar that's in the zip, 7zip doesn't load it. Either upload a standalone gci from the memcard manager or sanely zip your savefile.

#7 Updated by mlgsupersanik almost 3 years ago

JMC4789 wrote:

I can't load your rar that's in the zip, 7zip doesn't load it. Either upload a standalone gci from the memcard manager or sanely zip your savefile.

How about this file?

#8 Updated by Hiddennight almost 3 years ago

Did this issue ever get resolved or a workaround for this? I'm stuck at the same point and getting Unable to resolve write address 3fa8423f PC 508. There is about 30 errors like this that pop up and then Dolphin crashes and unable to go past this point. Tried running in admin mode and in compatibility mode to see if its a issue with Windows 10 but still seeing this issue.

#9 Updated by skidau almost 3 years ago

d13426a926055be11a8330b27fe231ea isn't a good dump. db9a997a617ee03bbc32336d6945ec02 is the good dump. Try dumping the game disc again and check if this issue continues.

#10 Updated by Hiddennight almost 3 years ago

I'm having this issue with MD5 Hash: db9a997a617ee03bbc32336d6945ec02 so that matches with a good dump

#11 Updated by Hiddennight almost 3 years ago

Hiddennight wrote:

I'm having this issue with MD5 Hash: db9a997a617ee03bbc32336d6945ec02 so that matches with a good dump

Still having this issue

#12 Updated by JosJuice almost 3 years ago

Are all cheats disabled?

#13 Updated by Hiddennight almost 3 years ago

Where do I check this at? I've not enabled any cheats for this game.

#14 Updated by JosJuice almost 3 years ago

If the "Enable Cheats" setting was turned on, you might have had some cheats enabled, so turn it off and test the issue again. If it was turned off, you didn't have any cheats enabled. (The list of specific cheats you've activated in this game can be seen by right-clicking on the game and going to the properties, but just turning off the general "Enable Cheats" setting is a simpler way to test whether the issue is caused by cheats.)

#15 Updated by Hiddennight almost 3 years ago

Enable Cheats check box is not checked. I've never enabled them either.

#16 Updated by JMC4789 about 2 years ago

  • Status changed from Questionable to Invalid

Didn't crash and I proceeded forward in the game.

Vulkan Backend on Single Core, all other settings set to defaults.

Also available in: Atom PDF