Project

General

Profile

Emulator Issues #10533

Conflict Desert Storm HLE audio FX constant crackling

Added by roadiex over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Conflict Desert Storm

Game ID? (right click the game in the game list, properties, info tab)

GCFP75

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

e756eead045d85efbafd7defae7155c0

What's the problem? Describe what went wrong.

New AX HLE appears to cause sound FX to crackle constantly. You can hear the effect simply by navigating the menu screen(audible as an extra 'click/pop sound' after the normal menu sounds when navigating).

In game, it causes crackling after any sound effect, e.g. gun shooting, footsteps etc). Does not seem to affect music.

In 3.5-33, the issue does not occur.

This is with HLE enabled, DSound or XAudio2 Backend

What steps will reproduce the problem?

Load up any Dolphin version after 3.5-33, using HLE audio, DSound or XAudio2

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[5.0-5451]

Is the issue present in the latest stable version?

[Yes 5.0]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number: 3.5-78 ]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[Core i7 4960x, GTX 1080Ti, Windows 10 x64 ver 1703, 64GB DDR3, Samsung 850 Pro SSD]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]


Related issues

Is duplicate of Emulator - Emulator Issues #10544: Streaming Audio Issues Across Many GameCube TitlesFixed

History

#1 Updated by JMC4789 over 1 year ago

Does it happen in LLE audio?

#2 Updated by roadiex over 1 year ago

JMC4789 wrote:

Does it happen in LLE audio?

Yes, I have done some more testing:

LLE Broken in 5.0-5451 and 5.0

LLE Also broken in 3.5-78 & 3.5-33

I also tried Dolphin 3.0, both HLE & LLE there is no sound at all

#3 Updated by xerxes over 1 year ago

Can confirm this on the NTSC-U version as well (GCFE9G) in master 5.0-5477. Can also confirm that it's been around a long time, since my old wiki test for this game on 4.0-4424 mentions it.

Here's an old IGN clip of the game on console with working audio: https://www.youtube.com/watch?v=snvLRD1aYFk

Here's Free Emulator's video of the game in 4.0.2 where you can hear the footsteps crackle (skip to 12:40, the very end): https://www.youtube.com/watch?v=Ak1Wp1BGuxY

#4 Updated by JMC4789 over 1 year ago

I've ordered this game and will see what I can do.

#5 Updated by JMC4789 over 1 year ago

  • Status changed from New to Duplicate

Combining into a bigger issue.

#6 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF