Project

General

Profile

Emulator Issues #10538

Aparoid Homeworld Has an odd Crash While Texture Dumping

Added by Dogstalotl about 2 years ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Star Fox Assault

Game ID? (right click the game in the game list, properties, info tab)

GF7E01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

992e00b7df1960d4ca03c76801502f91

What's the problem? Describe what went wrong.

While in the process of dumping the game's textures, I ran into a persistent problem in which the game would drop to about 20 FPS on average and crash after a short period of time while playing on the Aparoid Homeworld level (Stage 9). I tried disabling Duel Core (because Corneria has a crashing bug with it enabled (even when not dumping textures)) with no effect, I disabled the 16:9 hack with still no effect, I updated Dolphin and it still crashed, and I deleted the game save and speedran up to where I was and I still had the problem. I've tried about everything I could think of and the game won't stop crashing with a "*** Caught unhandled unknown exception; terminating" message.

What steps will reproduce the problem?

Unknown.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-5455

Is the issue present in the latest stable version?

Maybe? (It won't even load)

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU - i5-4690K
GPU - GTX 960
RAM - 16 GB DDR3 RAM
Motherboard - Gigabyte Z97X-Gaming 7
OS - Windows 10 Pro 64-bit

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Here's my settings:
https://imgur.com/a/SlY6e
and I also have SweetFX enabled.


Related issues

Is duplicate of Emulator - Emulator Issues #8935: Star Fox Assault - Crashing in Multiple StagesFixed

History

#1 Updated by Dogstalotl about 2 years ago

A while later, I started to see another error on top of the error listed. That error is was "Invalid read from (Varying number for each crash), PC = (Another Varying number for each crash)."

#2 Updated by Dogstalotl about 2 years ago

A little while after the last update on this, I decided to try the thing I didn't try at all. I disabled the Texture Dumping. Turns out that even with it off, the bug still persists.

#3 Updated by Nooga almost 2 years ago

I had this issue too. Try 5.0-78d5dbe-dirty build, it seems to be fixed as of that one.

#4 Updated by JosJuice almost 2 years ago

To translate that into the normal numbering scheme, 78d5dbe is 5.0-5686 (https://dolphin-emu.org/download/dev/78d5dbe032d4390fbc3bbfc81768b68c2062fa8f/).

#5 Updated by JMC4789 over 1 year ago

  • Status changed from New to Duplicate

#6 Updated by JMC4789 over 1 year ago

Also available in: Atom PDF