Project

General

Profile

Emulator Issues #10544

Streaming Audio Issues Across Many GameCube Titles

Added by JMC4789 over 2 years ago. Updated about 2 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:
5.0-5578

Description

Game Name?

Harry Potter and the Chamber of Secrets - GHSE69
Harry Potter and the Sorcerer's Stone - GHLE69
Hikaru No Go 3 - GHTJA4
Conflict: Desert Storm - GCFE9G
Looney Tunes: Back in Action - GLNE69

And likely other GameCube Streaming Audio Titles. I had a few other games that I knew ran into it but I can't think them up off the top of my head right now.

What's the problem? Describe what went wrong.

Fun times, I get to make multiple sections for this.

Harry Potter and the Sorcerer's Stone

Problem 1: Loads wrong audio tracks. Included a GCI file, just follow the video - https://youtu.be/Th8DY320MS0
Problem 2: Hangs on chess minigame before final boss. I included a second Harry potter GCI. Change filetype to .gci before using.

Harry Potter and the Chamber of Secrets

Problem 1: Crackling Audio. Simply start up the game and you'll run into crackling audio in the opening cutscene at the beginning and end of every sound loaded.

Conflict Desert Storm

Problem 1: Footsteps and other audio crackle. Simply load a new game and go to training camp and walk around.

Hikaru no Go 3

Problem 1: Game Hang. Start a new game and it'll hang almost immediately.

Looney Tunes: Back in Action

Problem 1: Lots of audio crackling throughout the game.
Problem 2: Loads wrong audio tracks. Use the Harry Potter save for an easier way to reproduce it.

What steps will reproduce the problem?

Most of these games have obvious hangs or issues, and for reproduction I've provided savefiles.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

These issues have happened in DSP-LLE since Dolphin's inception. New-AX-HLE brought these issues over to HLE audio, but the bug is not in the HLE implementation.

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

So you're probably wondering why I grouped all of these seemingly similar issues together. All of the hangs, crackling, and wrong music tracks loaded are the same bug showing up in different ways. I just wanted to make a single issue where we could group all the games so when this finally does get fixed, the wiki + ratings can be adjusted correctly.

69-GHLE-whog_harrypotter.gci (72.1 KB) 69-GHLE-whog_harrypotter.gci Harry Potter Wrong Audio JMC4789, 09/14/2017 09:30 PM
69-GHLE-whog_harrypotter.gcibak2 (72.1 KB) 69-GHLE-whog_harrypotter.gcibak2 Harry Potter Hang JMC4789, 09/14/2017 09:30 PM

Related issues

Has duplicate Emulator - Emulator Issues #8425: Constant crackling sound in Harry Potter and the Chamber of SecretsDuplicate

Has duplicate Emulator - Emulator Issues #8096: Terrible sound in Harry Potter and the Sorcerer's Stone (both HLE and LLE)Duplicate

Has duplicate Emulator - Emulator Issues #8305: Looney Tunes: Back In Action - Random sound effects and loud audio cracklingDuplicate

Has duplicate Emulator - Emulator Issues #10533: Conflict Desert Storm HLE audio FX constant cracklingDuplicate

Has duplicate Emulator - Emulator Issues #6780: Hikaru no Go 3: non-responsive to inputDuplicate

History

#1 Updated by JMC4789 over 2 years ago

  • Has duplicate Emulator Issues #8425: Constant crackling sound in Harry Potter and the Chamber of Secrets added

#2 Updated by JMC4789 over 2 years ago

  • Has duplicate Emulator Issues #8096: Terrible sound in Harry Potter and the Sorcerer's Stone (both HLE and LLE) added

#3 Updated by JMC4789 over 2 years ago

  • Has duplicate Emulator Issues #8305: Looney Tunes: Back In Action - Random sound effects and loud audio crackling added

#4 Updated by JMC4789 over 2 years ago

#5 Updated by JMC4789 over 2 years ago

#6 Updated by FireNX70 about 2 years ago

For curiosity's sake, what was the hack that fixed this?

#7 Updated by JMC4789 about 2 years ago

This hack, which is not a real solution, is

Modify Line 192 of AXVoice to if (acc_end_reached || !acc_pb->running)

This only fixes it in HLE audio, when the bug is common between HLE and LLE.

#8 Updated by FireNX70 about 2 years ago

Ok, thanks. As I said, it's just curiosity. I know a hack should not be the solution.

#9 Updated by JMC4789 about 2 years ago

Yeah but if you want to play one of the affected games right now, this should work ;)

That's what I used it for lol.

#10 Updated by leoetlino about 2 years ago

  • Status changed from New to Work started
  • Assignee set to leoetlino

#11 Updated by leoetlino about 2 years ago

  • Status changed from Work started to Fix pending

#12 Updated by leoetlino about 2 years ago

  • Status changed from Fix pending to Fixed
  • Fixed in set to 5.0-5578

Also available in: Atom PDF