Project

General

Profile

Emulator Issues #10556

Brunswick Zone: Cosmic Bowling is rendered wrong

Added by TrivialMan almost 2 years ago. Updated 7 months ago.

Status:
Accepted
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Brunswick Zone: Cosmic Bowling

Game ID? (right click the game in the game list, properties, info tab)

SBKEPZ

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

3603289F001D72164252DB789EC67249

What's the problem? Describe what went wrong.

The game has some sort of issue rendering that causes it to keep displaying things wrong on each backend. In D3D11 it's really zoomed in at different places and flashing black. It's bad enough it hurt my eyes trying to make it past the Wiimote warning screen and logos, and the main menu didn't work with it either. In OpenGL things are all stretched out and somewhat flashy. With software rendering the game just crashes.

What steps will reproduce the problem?

Boot up the game. It does it from the very first screen you see.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Dolphin 5.0-5581

Is the issue present in the latest stable version?

It is still present in Dolphin 5.0

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

The attached fifolog is from the first screen of the game, the normally static Wiimote warning screen about knocking over vases and such.

What are your PC specifications? (CPU, GPU, Operating System, more)

AMD FX-6300 Six-Core Processor
NVIDIA GeForce GTX 750 Ti
Windows 7 64-bit

History

#1 Updated by JMC4789 almost 2 years ago

You appear to be making issue reports about shovelware

It's very possible the game works but needs settings,but because it's not very popular no users have reported it.

Can you try enabling XFB emulation (Graphics Settings/Hacks) or the various other settings on that page?

Thanks. If nothing helps, please notify me and I'll order the game and give it a shot.

#2 Updated by TrivialMan almost 2 years ago

Real XFB fixes it. Thanks.

#3 Updated by JMC4789 almost 2 years ago

  • Status changed from New to Accepted

HybridXFB should fix stuff like this by default.

#4 Updated by JMC4789 7 months ago

  • Assignee set to JosJuice

It is fixed on the default settings. But, we should make sure that Immediately Display XFB is disabled in the INI anyway.

Also available in: Atom PDF