Project

General

Profile

Emulator Issues #10569

Crash when a save gets written in Super Mario Galaxy

Added by Terg500 almost 4 years ago. Updated almost 4 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Super Mario Galaxy

Game ID? (right click the game in the game list, properties, info tab)

RMGE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

3114a76b9a0e43fb111b97380b50ebc3

What's the problem? Describe what went wrong.

When a save gets written (happens at random, not every time) Dolphin freezes and a Warning is displayed. It reads "Invalid read from 0x00000011, PC = 0x804827b0"

What steps will reproduce the problem?

Finishing a stage and confirming to save the game.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-5634

What are your PC specifications? (CPU, GPU, Operating System, more)

Intel i7-7700K
GTX 970
Windows 10 Pro x64
Wiimote + Nunchuck with Dolphinbar V.09

dolphinsmg.png (2.75 KB) dolphinsmg.png Terg500, 10/05/2017 08:32 PM
6377

History

#1 Updated by JosJuice almost 4 years ago

Does it happen in 5.0?

#2 Updated by JMC4789 almost 4 years ago

That doesn't match any known good dumps of Super Mario Galaxy.

I've played through Super Mario Galaxy and never ran into a crash on save. You may want to try switching to a different NAND, yours may be corrupted and that could also cause issues. Considering how Dolphin has treated NANDs in the past... it's very likely to be corrupted, though, I haven't seen a crash caused by it in this game.

#3 Updated by Terg500 almost 4 years ago

JMC4789 wrote:

That doesn't match any known good dumps of Super Mario Galaxy.

I've played through Super Mario Galaxy and never ran into a crash on save. You may want to try switching to a different NAND, yours may be corrupted and that could also cause issues. Considering how Dolphin has treated NANDs in the past... it's very likely to be corrupted, though, I haven't seen a crash caused by it in this game.

I think my game was the problem. I dumped my game again, this time using CleanRip instead of Friidump, and it seems to have fixed the problem. I could play 2 hours straight today without problem.

#4 Updated by JosJuice almost 4 years ago

  • Status changed from New to Invalid

Rawdump/Friidump are known to be a bit finicky, so that makes sense.

Also available in: Atom PDF