Project

General

Profile

Emulator Issues #10593

Graphical bugs in Skyward Sword with AMDGPU and Vulkan

Added by Lignum about 2 years ago. Updated almost 2 years ago.

Status:
New
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Linux
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

The Legend of Zelda: Skyward Sword

Game ID? (right click the game in the game list, properties, info tab)

SOUE01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

5f89d637da16cde158f0d6cf0993892f

What's the problem? Describe what went wrong.

The main menu renders incorrectly with Vulkan, with most of the background having a translucent white overlay, except for the bottom right corner. In the game itself, the depth of field's focal point is way too close to the camera, and shadows of non-stationary game objects either have artifacts or render another object's shadow, it likes to cycle through both possibilities now and then.

The game looks fine on other backends, however the Vulkan backend does work fine on Windows with the Crimson drivers (same hardware).

What steps will reproduce the problem?

Start the game with AMDGPU on the Vulkan backend and behold.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, tested on 5.0-5681.

Is the issue present in the latest stable version?

I'm having trouble building it, and the pre-built on pacman gets a SIGABRT, so sorry, no idea.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

-

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

The fifo logs are too big to upload, sorry, however the screenshots should sum it up pretty well.

What are your PC specifications? (CPU, GPU, Operating System, more)

CPU: AMD Ryzen 1700
GPU: Sapphire Radeon RX580
Operating System: Arch Linux (with Wayland)
Graphics Driver: AMDGPU 1.4.0 (Mesa 17.2.2)

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Twilight Princess exhibits the same shadow weirdness, but works fine otherwise. Fiddling with the settings does not seem to affect the behaviour.

menu.png (925 KB) menu.png Weird main menu Lignum, 10/19/2017 11:15 PM
game.jpg (515 KB) game.jpg In-game (note the DOF); Link's shadow is actually the one of the NPC in the background on the left Lignum, 10/19/2017 11:17 PM
shadow_artifacts.png (258 KB) shadow_artifacts.png Link's shadow has tiny holes in it Lignum, 10/19/2017 11:19 PM
shadows.jpg (255 KB) shadows.jpg Same shadow artifacts on NPC, Link has NPC's shadow Lignum, 10/19/2017 11:21 PM
SOUP01-2.png (109 KB) SOUP01-2.png Missing map lkreq, 11/12/2017 06:06 AM
9RMu.jpg (530 KB) 9RMu.jpg Link's head and the ornament in the top left are obstructed by a jagged line Lignum, 11/15/2017 12:34 PM
6397
6398
6399
6401
6434
6443

History

#1 Updated by Helios about 2 years ago

  • Operating system Linux added
  • Operating system deleted (N/A)

Compress the fifolog with zip or something. it compresses very well. 4 frames should be enough.

#2 Updated by Lignum about 2 years ago

Helios wrote:

Compress the fifolog with zip or something. it compresses very well. 4 frames should be enough.

No chance, even with compression, I can't get it below 30MB, and that's just a single frame of the main menu.

#3 Updated by lkreq almost 2 years ago

6434

I have all the same issues described Lignum:
CPU: G4560
GPU: XFX RX460
OS: Debian Testing (Buster)
Graphics Driver: AMDGPU 1.4.0 (Mesa 17.2.4)

In addition I lose map visibility (screenshot). I was using 5.0-5410 and now using 5.0-5815 with similar results.

#4 Updated by Lignum almost 2 years ago

6443

lkreq wrote:

I have all the same issues described Lignum:
CPU: G4560
GPU: XFX RX460
OS: Debian Testing (Buster)
Graphics Driver: AMDGPU 1.4.0 (Mesa 17.2.4)

In addition I lose map visibility (screenshot). I was using 5.0-5410 and now using 5.0-5815 with similar results.

I indeed also have a broken map, exactly as in that screenshot, I just hadn't thought to look there beforehand.

Additionally, when antialiasing is enabled, a diagonal jagged line that renders some objects transparent appears across the screen (see screenshot).

Also available in: Atom PDF