Project

General

Profile

Emulator Issues #10601

Sonic Adventure 2 Battle crashes during Kart Race

Added by alexchandel over 2 years ago. Updated almost 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Shortly after starting a kart race, Dolphin freezes the game and produces an endless loop of errors dialogs, iterating through the messages:

  • Invalid read from 0x00000014, PC = 0x80071934
  • Invalid read from 0x00000000, PC = 0x80071934
  • Invalid read from 0x0000000c, PC = 0x80071954

or sometimes:

  • Invalid read from 0x00000014, PC = 0x800719dc
  • Invalid read from 0x00000000, PC = 0x800719dc
  • Invalid read from 0x0000000c, PC = 0x800719fc

The game never closes, but never unfreezes. Notably, there is no way to exit this loop shorting of forcibly killing Dolphin's process. Also in one instance, Dolphin produced a different error message: "IntCPU: Unknown instruction 00000000 at PC = 7f5e57d8 last_PC = 81200c9c LR = 80
071954". This dialog had two cryptic options, "Yes" and "No," but at least "No" quit Dolphin.

Tested on macOS 10.13, Dolphin build 5686.

Screen Shot 2017-10-22 at 8.50.22 PM.png (3.25 MB) Screen Shot 2017-10-22 at 8.50.22 PM.png error dialog alexchandel, 10/23/2017 01:55 AM
6409

Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by alexchandel over 2 years ago

Update: as of build 5698, this has regressed even further. Now Dolphin hangs even sooner, and doesn't display any error dialogs at all. It just freezes & blares a loud tone until the game is closed.

#2 Updated by alexchandel over 2 years ago

I managed to trigger this bug in the Boss minigame as well.

On Build 5698, after the 4th boss fight in the boss minigame (King Boom Boo), Dolphin crashes with infinite error dialogs along the lines of "Invalid read from 0x81806db8 PC = 0x8011d2b4".

#3 Updated by Nooga over 2 years ago

Sounds like a duplicate of issue 7143 - turn off dual core to do cart races without crashing. Not sure about boss minigame though.

#4 Updated by JMC4789 almost 2 years ago

  • Status changed from New to Duplicate

Confirmed

#5 Updated by JMC4789 almost 2 years ago

Also available in: Atom PDF