Project

General

Profile

Emulator Issues #10604

Pokemon Colosseum character shakes if emulation speed is unlimited

Added by knightmustard almost 3 years ago. Updated almost 3 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Pokemon Colosseum

Game ID? (right click the game in the game list, properties, info tab)

GC6E01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

e3f389dc5662b9f941769e370195ec90

What's the problem? Describe what went wrong.

The character shakes back and forth very quickly when emulation speed is set to unlimited. It occurs while walking around but is most noticeable during cutscenes of driving to another town.

What steps will reproduce the problem?

Set emulation speed to unlimited and walk around or travel to a town.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.
5.0-5698

What are your PC specifications? (CPU, GPU, Operating System, more)
ArchLinux, Nvidia 940MX, OpenGL, JIT


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by MayImilae almost 3 years ago

  • Status changed from New to Working as intended

When using unlimited frame rate, it goes really fast. Shocking! So um, don't use unlimited? Or get a slower computer. :3

#2 Updated by Helios almost 3 years ago

To clarify, what you're likely seeing here is the character idle animation. Very subtle when playing at normal speed. Easier to see at higher speed.

#3 Updated by knightmustard almost 3 years ago

I'm not entirely confident it is just the animation while the speed is higher. For example, during cutscenes of driving to another town, the vehicle is only moving in one direction with some animations too. However when it is sped up it looks like the actual position of vehicle is teleporting back and forth.

#4 Updated by knightmustard almost 3 years ago

Here is a video of it. https://youtu.be/c-Gwo8xDtaQ
The recording is at 30 fps. I had the speed limit on Dolphin at 200% to keep it looking consistant.

#5 Updated by knightmustard almost 3 years ago

knightmustard wrote:

Here is a video of it. https://youtu.be/c-Gwo8xDtaQ
The recording is at 30 fps. First clip is normal, the second clip is with the speed limit higher. I set the speed limit on Dolphin at 200% to keep it looking consistent.

#6 Updated by knightmustard almost 3 years ago

Here is a video of it. https://youtu.be/c-Gwo8xDtaQ
The recording is at 30 fps. First clip is normal, the second clip is with the speed limit higher. I set the speed limit on Dolphin at 200% to keep it looking consistent.

#7 Updated by JMC4789 almost 3 years ago

  • Status changed from Working as intended to Invalid

Turn off dualcore.

#8 Updated by JMC4789 almost 3 years ago

  • Status changed from Invalid to Duplicate

Or I guess this is a duplicate really.

#9 Updated by JMC4789 almost 3 years ago

Also available in: Atom PDF