Project

General

Profile

Emulator Issues #10656

Pac-Man World 2 now requires VSync to be turned off

Added by CJB100 over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Pac-Man World 2
GP2P69
Not putting hash, use Launchbox to launch games, nothing in dolphin listing. It's a good dump of the game.

Pac-Man World 2 has required Real XFB for the movie cutscenes for a while, but lately the game fails to load past the intro cutscenes if vsync is also enabled in full screen. Switching from full screen to windowed right before the title screen is supposed to load can usually completely mitigate the issue, but once back in full screen, after the next movie cutscene plays, game freezes trying to load in-engine scenes or gameplay. This can be completetly fixed by adding "[Video_Hardware] VSync = False" to the game's ini file, but I'm wondering what caused the issue to arise? This occurs in all current graphics backends.

Reproducing the problem:
1. Enable Real XFB (currently this should happen on game open) and VSync.
2. Launch game in full screen mode.
3. Press "A" after Title Screen movie plays to skip intro or let intro play out.
4. Game seems to freeze as it loads the title screen

Present in Dolphin 5.0-5831, probably for a while judging by some reddit posts dating two months back.

Windows 10
Intel Core i5
4GB DDR3
Radeon RX 550 4GB
500GB 3.5" HDD


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 over 2 years ago

  • Status changed from New to Duplicate

This is an issue with dualcore timing. This doesn't happen in single core as far as I can tell.

#2 Updated by JMC4789 over 2 years ago

#3 Updated by JosJuice over 2 years ago

#4 Updated by JosJuice over 2 years ago

Also available in: Atom PDF