Project

General

Profile

Actions

Emulator Issues #10659

closed

Dolphin not detecting my Mayflash GC 4-port adapter

Added by okod over 6 years ago. Updated about 5 years ago.

Status:
Fixed
Priority:
Normal
Assignee:
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.

Dolphin refuses to detect my mayflash adapter. I installed everything correctly, used zadig 2.3, followed anther's guide to setting everything up, and my drivers appear to be working with my WUP-028 being displayed properly under USB. I reinstalled several times, and used many different usb ports to try to solve this. I have gone through almost all troubleshooting steps using the wiki to try to solve this. I spoke with the FM team for advice, and after much talk, they suggested I report this as a bug.

What steps will reproduce the problem?

  1. Connecting my mayflash adapter to my usb.
  2. Opening dolphin and seeing "No adapter detected".

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-5931.

Is the issue present in the latest stable version?

Yes tested Dolphin 5.0 and FM 5.7.

What are your PC specifications? (CPU, GPU, Operating System, more)

Mobo: ASrock AB350 Pro4
CPU: Ryzen 5 1500x 3.5 GHZ
GPU: Radeon 480X 4gb
Memory: 16GB Ballistix Sport LT 8GB DDR4 2666 x2
OS: Windows 7 Ultimate

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I upgraded to windows 10 to see if it would solve the issue, and it did, everything worked perfectly. However, when I reinstalled back to my windows 7 setup, it went back to not detecting the adapter.

Actions #1

Updated by JMC4789 over 6 years ago

  • Status changed from New to Questionable
  • Assignee set to leoetlino

If changing the operating system fixed it, that suggests there's something wrong with setup outside of Dolphin.

It could be a bug in Windows 7 with your hardware that they fixed in Windows 8/10, it could be a bug in Zadig on Windows 7, and it could be a bug in Dolphin on Windows 7. There's not enough information on this issue report for us to do anything.

I'll see if I can grab someone who can help us figure out what we'd need to see what libusb is doing.

Actions #2

Updated by okod over 6 years ago

Ok, I see. I appreciate any help I can get to figure this out. I've been going pretty crazy trying to get this to work. Also, I don't know if this helps, but the Digital Signer is "USB\VID_057E&PID_0337 (libwdi autogenerated)". Not sure if that's normal or not.

Actions #3

Updated by Wandan03 over 5 years ago

I had the same issue with my R5 1400, MSI B350m Pro VDH also running Windows 7, a 'solution' if you still want to use Windows 7 is buying a USB PCIE card and and plugging the adapter into those expansion card's USB ports and not the motherboards. I used Syba SD-PEX20139 and it works perfectly. Hopefully this sheds some light on the problem and it can get working on the motherboards USB ports under Windows 7.

Actions #4

Updated by Wandan03 about 5 years ago

A bit of an update, it seems as it's not an issue with Zadig but an issue with Dolphin running on Windows 7 possibly.
https://github.com/pbatard/libwdi/issues/150
Hopefully one of the devs can look into this.

Actions #5

Updated by Wandan03 about 5 years ago

This is fixed as of Dolphin 5.0-9320!

Actions #6

Updated by JosJuice about 5 years ago

  • Status changed from Questionable to Fixed

I'll close the issue, then.

Actions #7

Updated by Wandan03 about 5 years ago

Bringing this up again, so on 5.0-9320 with a X470 motherboard Dolphin detected my Mayflash adapter under Wii U mode just fine, now I'm on 5.0-9595 Dolphin says the adapter isn't detected BUT I can use the controller just fine in game. On my friend's B350 motherboard he still has to use the PCI-E adapter in order to use his Gamecube adapter. Is there any log files that could possibly help solve this?

Actions

Also available in: Atom PDF