Project

General

Profile

Emulator Issues #10671

System crash when launching the bobsleigh minigame of Wii Party

Added by PureTryOut over 3 years ago. Updated about 3 years ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

When trying to play the bobsleigh minigame of the game Wii Party, the system grinds to a full halt. Nothing responds anymore, I can't even switch to a TTY and I have to power cycle my PC. Other minigames work fine however.

System is Gentoo Linux, Linux 4.14, running on OpenGL on a AMD RX480. The CPU is an AMD R7 1700. I've compiled the latest version of Git from today (27th November 2017).

History

#1 Updated by ahenke over 3 years ago

PureTryOut wrote:

When trying to play the bobsleigh minigame of the game Wii Party, the system grinds to a full halt. Nothing responds anymore, I can't even switch to a TTY and I have to power cycle my PC. Other minigames work fine however.

System is Gentoo Linux, Linux 4.14, running on OpenGL on a AMD RX480. The CPU is an AMD R7 1700. I've compiled the latest version of Git from today (27th November 2017).

Try Using Direct3D. It work for me

#2 Updated by PureTryOut over 3 years ago

ahenke wrote:

Try Using Direct3D

That is kinda hard on a Linux system.

#3 Updated by ahenke over 3 years ago

PureTryOut wrote:

ahenke wrote:

Try Using Direct3D

That is kinda hard on a Linux system.

Dosent Linux have Direct3D? I swear it has.

#4 Updated by JMC4789 over 3 years ago

It's very hard for Dolphin to crash the system itself - it is probably an issue with your graphics drivers and not a fault of Dolphin. Or if Dolphin is doing something wrong, the fact it's crashing your system is still a fault of the driver.

Figuring out what Dolphin is doing to crash the system is important, but, I'm not exactly sure how we could figure it out. Odds are since it works on Windows under both AMD and NVIDIA (OGL for me) that Dolphin isn't doing anything abnormal.

#5 Updated by PureTryOut over 3 years ago

ahenke wrote:

Dosent Linux have Direct3D? I swear it has.

It does not. Only OpenGL and Vulkan are available, as Direct3D comes from DirectX, which is obviously not available.

JMC4789 wrote:

It's very hard for Dolphin to crash the system itself - it is probably an issue with your graphics drivers and not a fault of Dolphin.

Makes sense. It's just a bit weird that it always happens with that specific minigame. I'll try a different video render and report back.

#6 Updated by JMC4789 over 3 years ago

Some things can use very specific features. Like, Super Mario Sunshine is one of the only games to use perfqueries.

#7 Updated by ahenke over 3 years ago

I Would say just to use RNG Manipulation to not get that minigame (unless your wanting to play it)

Ive had this issue before and was fixed for me by switching the render.

See if you can get it to work by playing around with the settings

#8 Updated by JMC4789 over 3 years ago

  • Status changed from New to Questionable

Does this minigame have trouble in general? I mean, if it's happening in one driver/renderer, then there's probably not much that can be done. But if a bunch of drivers are having issues, maybe dolphin is doing something less good.

#9 Updated by JMC4789 about 3 years ago

  • Status changed from Questionable to Invalid

Also available in: Atom PDF