Project

General

Profile

Emulator Issues #10692

Issue with wtk while building rpm in fedora 27 with mock

Added by jlozadad about 4 years ago. Updated about 4 years ago.

Status:
Won't fix
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
Linux
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

What's the problem? Describe what went wrong.
trying to create a rpm for fedora 27 with the latest pushes on master. After running fedpkg --release f27 mockbuild I get some errors. Build logs attached:

fedpkg --release f27 mockbuild
sources file doesn't exist. Source files download skipped.
Failed to get module name from Git url or pushurl

Wrote: /home/jcasanova/Downloads/git/dolphin-emu/source_build/dolphin-emu-5.10-17.fc27.src.rpm
INFO: mock.py version 1.4.7 starting (python version = 3.6.3)...
Start: init plugins
INFO: selinux disabled
Finish: init plugins
Start: run
INFO: Start(/home/jcasanova/Downloads/git/dolphin-emu/source_build/dolphin-emu-5.10-17.fc27.src.rpm)  Config(fedora-27-x86_64)
Start: clean chroot
Finish: clean chroot
Start: chroot init
INFO: calling preinit hooks
INFO: enabled root cache
Start: unpacking root cache
Finish: unpacking root cache
INFO: enabled dnf cache
Start: cleaning dnf metadata
Finish: cleaning dnf metadata
INFO: enabled HW Info plugin
Mock Version: 1.4.7
INFO: Mock Version: 1.4.7
Start: dnf update
Last metadata expiration check: 0:00:00 ago on Fri 08 Dec 2017 11:48:55 PM EST.
Dependencies resolved.
Nothing to do.
Complete!
Finish: dnf update
Finish: chroot init
Start: build phase for dolphin-emu-5.10-17.fc27.src.rpm
Start: build setup for dolphin-emu-5.10-17.fc27.src.rpm
ERROR: Exception(/home/jcasanova/Downloads/git/dolphin-emu/source_build/dolphin-emu-5.10-17.fc27.src.rpm) Config(fedora-27-x86_64) 0 minutes 8 seconds
INFO: Results and/or logs in: /home/jcasanova/Downloads/git/dolphin-emu/source_build/results_dolphin-emu/5.10/17.fc27
INFO: Cleaning up build root ('cleanup_on_failure=True')
Start: clean chroot
Finish: clean chroot
ERROR: Command failed: 
 # /usr/bin/systemd-nspawn -q -M bff197efe2ce4dcbbdfb65032c8b0c22 -D /home/jcasanova/mock/fedora-27-x86_64/root -a --private-network --setenv=TERM=vt100 --setenv=SHELL=/bin/bash --setenv=HOME=/builddir --setenv=HOSTNAME=mock --setenv=PATH=/usr/bin:/bin:/usr/sbin:/sbin --setenv=PROMPT_COMMAND=printf "\033]0;<mock-chroot>\007" --setenv=PS1=<mock-chroot> \s-\v\$  --setenv=LANG=en_US.UTF-8 -u mockbuild /bin/rpm -Uvh --nodeps /builddir/build/originals/dolphin-emu-5.10-17.fc27.src.rpm

Could not execute mockbuild: Command '['mock', '-r', 'fedora-27-x86_64', '--resultdir', u'/home/jcasanova/Downloads/git/dolphin-emu/source_build/results_dolphin-emu/5.10/17.fc27', '--rebuild', u'/home/jcasanova/Downloads/git/dolphin-emu/source_build/dolphin-emu-5.10-17.fc27.src.rpm']' returned non-zero exit status 1


What steps will reproduce the problem?
Download source rpm for dolphin-emu
git clone master
change dolphin-emu.spec to use latest git project
add rpmfusion repos to /etc/mock/default.cfg so mock grabs all the required rpms
run fedpkg --release f27 mockbuild

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Version number here]
1a9d6b99e95547bd8aadb8b287bbf8ae949ba7a2 Latest from master as of today. 12/08/2017

[Yes/No and version number here]
Yes, version 5.0 stable builds successfully.

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]
fedora 27
Nvidia GTX 755 TI

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]
logs have been attached

[Put Game Name here]

Game ID? (right click the game in the game list, properties, info tab)

[Put Game ID here]

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

[Put MD5 Hash here]

What's the problem? Describe what went wrong.

[Description here]

What steps will reproduce the problem?

[Reproduction steps here]

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

[Version number here]

Is the issue present in the latest stable version?

[Yes/No and version number here]

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

[First broken version number here (if applicable)]

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

[Attach any fifologs if possible, write a description of fifologs and screenshots here to assist people unfamiliar with the game.]

What are your PC specifications? (CPU, GPU, Operating System, more)

[PC specs here]

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

[Anything else here]

build.log (59.6 KB) build.log jlozadad, 12/09/2017 04:50 AM

History

#1 Updated by Helios about 4 years ago

  • Status changed from New to Won't fix
  • Operating system Linux added
  • Operating system deleted (N/A)

It isn't our job to resolve distro packaging problems as we don't ship distro specific packages anymore. However, you can request help on the forums.

Also available in: Atom PDF