Project

General

Profile

Emulator Issues #10704

Kirby 64: The Crystal Shards OpenAL Garbled Audio

Added by kolano about 1 year ago. Updated about 2 months ago.

Status:
Questionable
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Kirby 64: The Crystal Shards

Game ID? (right click the game in the game list, properties, info tab)

NAME01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

4c1defbd71d273ce881f26c17fd59ceb (wad unsigned by Nintendo)

What's the problem? Describe what went wrong.

Audio with OpenAL is garbled, but seems to play fine with all other backends.

This should be irrelevant if / once the CubeB backend can replace OpenAL.

What steps will reproduce the problem?

Play with audio set to use OpenAL.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-6004

Is the issue present in the latest stable version?

Yes

What are your PC specifications? (CPU, GPU, Operating System, more)

i7-6700K, NVIDIA 970, Windows 10

History

#1 Updated by JMC4789 about 2 months ago

  • Status changed from New to Questionable

Does this still happen? We fixed an issue a while back with OpenAL having garbled audio when booting certain games.

#2 Updated by kolano about 2 months ago

Not sure. My NAS is still offline, so I'm unable to test atm.

#3 Updated by danileon95 about 2 months ago

JMC4789 wrote:

Does this still happen? We fixed an issue a while back with OpenAL having garbled audio when booting certain games.

I just tested. I can confirm the sound is still garbled with this game when using OpenAL.

Also available in: Atom PDF