Project

General

Profile

Emulator Issues #10719

Android: Star Fox: Assault, Winged Aparoid boss dissappears during molten rocks attack

Added by ryanebola16 over 2 years ago. Updated over 2 years ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Star Fox: Assault

Game ID? (right click the game in the game list, properties, info tab)

GF7E01

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

383bfb280420240d11f7ba993fa0b061

What's the problem? Describe what went wrong.

Stage 1 boss disappears during the molten rocks attack. The stage will still progress in a loop but the boss cannot be damaged so the stage can't be beaten. This problem does not occur on the Windows build.

What steps will reproduce the problem?

  1. Try to complete the 1st stage of the game.

What are your PC specifications? (CPU, GPU, Operating System, more)

Samsung Galaxy Note8 (SM-N950U)
Qualcomm Snapdragon 835
Octa-core (4x2.35 GHz Kryo & 4x1.9 GHz Kryo)
Adreno 540
6GB RAM (LPDDR4)
Baseband version N950USQS2BQK2
Kernel version 4.4.21
Android 7.1.1

Android.jpg (791 KB) Android.jpg Boss is missing ryanebola16, 12/19/2017 04:15 AM
Windows.png (2.43 MB) Windows.png Boss is present ryanebola16, 12/19/2017 04:16 AM
6493
6494

Related issues

Is duplicate of Emulator - Emulator Issues #10722: Android: Add individual game INIFixed

History

#1 Updated by ryanebola16 over 2 years ago

Tested on Android and Windows using 5.0-6033

#2 Updated by JMC4789 over 2 years ago

It should work in interpreter.

#3 Updated by ryanebola16 over 2 years ago

Works in interpreter.

More importantly, works on JIT ARM64 Recompiler when importing GF7.ini and GF7E01.ini into Dolphin on Android!

Probably due to still needing FPRF. Thanks for reminding me of that!

Getting individual game INI's into Dolphin on Android would be nice!

#4 Updated by ryanebola16 over 2 years ago

Added #10722 to help solve this problem for others.

#5 Updated by JosJuice over 2 years ago

#6 Updated by JosJuice over 2 years ago

  • Status changed from New to Duplicate

Also available in: Atom PDF