Project

General

Profile

Emulator Issues #10761

Medal of Honor: Heroes 2 Unknown Opcode

Added by kolano about 2 years ago. Updated about 1 year ago.

Status:
Invalid
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Medal of Honor: Heroes 2

Game ID? (right click the game in the game list, properties, info tab)

RM2E69

What's the problem? Describe what went wrong.

Unknown opcode occur shortly after starting play, graphics output is incorrect with a black box in the lower right corner and constant flickering. Has been reported to hang Dolphin, but that was on the very old 3.0-765. I seems there is a revised game file posted through the forums that resolves some of this, but I hadn't retested that.

What steps will reproduce the problem?

Start title, select "Arcade", OK a few prompts, Watch opcode errors spew.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

5.0-6004

Is the issue present in the latest stable version?

Yes, 5.0

If the issue isn't present in the latest stable version, which is the first broken version? (You can find the first broken version by bisecting. Windows users can use the tool https://forums.dolphin-emu.org/Thread-green-notice-development-thread-unofficial-dolphin-bisection-tool-for-finding-broken-builds and anyone who is building Dolphin on their own can use git bisect.)

First reported /w 3.0-765

What are your PC specifications? (CPU, GPU, Operating System, more)

it-6700K, GeForce 970, Windows 10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

Replacement file: http://forums.dolphin-emu.org/attachment.php?aid=8808 (put into the %userprofile%/Documents/Dolphin Emulator/Wii/ticket/00000001/)

History

#1 Updated by JMC4789 over 1 year ago

Have you tried single core?

#2 Updated by kolano over 1 year ago

I'm currently unable to replicate this with 5.0-6917. Though I need to double check the status of that tik file.

#3 Updated by JMC4789 about 1 year ago

  • Status changed from New to Invalid

Can't reproduce the issue either. Assuming bad dump or other problems. Even dualcore works fine.

Also available in: Atom PDF