Project

General

Profile

Emulator Issues #10776

Sonic Adventure 2 Battle - Dual Core graphical errors and crash on Route 101

Added by Helios over 1 year ago. Updated over 1 year ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Current
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Sonic Adventure 2 Battle

Game ID? (right click the game in the game list, properties, info tab)

GSNE8P

MD5 Hash? (right click the game in the game list, properties, info tab, MD5 Hash: Compute)

9ef5fadf4b8756af820df997468a5a16

What's the problem? Describe what went wrong.

Tail's Route 101 level has severe skybox flickering and an invalid read error crash on dual core mode

What steps will reproduce the problem?

From the main menu

  1. 1P mode > Story Mode > Hero Mode (may be reproducible in stage select as well)

  2. Upon the start of Tail's Route 101 mission, the skybox errors should be immediately apparent, the crash happens 10-60 seconds later.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes - 5.0-6164

Is the issue present in the latest stable version?

Yes - 5.0

If your issue is a graphical issue, please attach screenshots and record a three frame fifolog of the issue if possible. Screenshots showing what it is supposed to look like from either console or older builds of Dolphin will help too. For more information on how to use the fifoplayer, please check here: https://wiki.dolphin-emu.org/index.php?title=FifoPlayer

FIFO is hard because the flickering only happens for a handful of frames sporadically every second

What are your PC specifications? (CPU, GPU, Operating System, more)

4790k
GTX 980 ti (driver 388.59)
Windows 10

Is there anything else that can help developers narrow down the issue? (e.g. logs, screenshots,
configuration files, savefiles, savestates)

I've attached the memcard with the save and my config files, but here are my config settings. Assume default unless stated otherwise

Graphics:

Backend: D3D11
V-Sync: On
Fullscreen: On
IR: 4x
AA: 4x MSAA
AF: 16x
Ubershaders: Hybrid

Config.zip (1.81 KB) Config.zip Helios, 01/12/2018 12:10 AM
memcard_gci.zip (5.92 KB) memcard_gci.zip Helios, 01/12/2018 12:10 AM

Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by Helios over 1 year ago

I forgot to mention, none of these things happen with DC off.

#2 Updated by Helios over 1 year ago

Bug worked around in https://dolphin-emu.org/download/dev/93979cd16adfbabc572732cf336666955798a64a/

Up to somebody else if they want to consider this resolved.

#3 Updated by JosJuice over 1 year ago

#4 Updated by JosJuice over 1 year ago

  • Status changed from New to Duplicate

Merging into the dual core master issue, which is not a blocker.

Also available in: Atom PDF