Project

General

Profile

Emulator Issues #10809

Second Sight horrible framerate drops/chugging with Dual Core

Added by xerxes about 2 years ago. Updated 10 months ago.

Status:
Duplicate
Priority:
Normal
Assignee:
-
% Done:

0%

Operating system:
N/A
Issue type:
Bug
Milestone:
Regression:
No
Relates to usability:
No
Relates to performance:
No
Easy:
No
Relates to maintainability:
No
Regression start:
Fixed in:

Description

Game Name?

Second Sight

Game ID?

GISE36

MD5 Hash?

9c14c0e39cdb9166999e49fc1ef44fd8 (confirmed with redump)

What's the problem? Describe what went wrong.

The game constantly drops to half the normal framerate or lower to the point of almost being a still image in various segments (while still running at full speed). It's tied to loading in new zones apparently, since it mostly occurs when opening doors to new areas or turning the camera around a corner. With dual core disabled, these drops do not occur, and the game holds a stable 60FPS.

What steps will reproduce the problem?

Start a new game, and when you leave the lab and get the healing power, kill the guards at the end of the hallway with the elevator. You can trigger the framerate drops by running up and down this hallway spinning the camera and opening the door back to the starting area over and over again.

Is the issue present in the latest development version? For future reference, please also write down the version number of the latest development version.

Yes, 5.0-6203

Is the issue present in the latest stable version?

Yes, it happens in 5.0 as well

What are your PC specifications?

Intel Core i3-3220 @ 3.3GHz, NVIDIA GeForce GTX 1060 6GB, Windows 10


Related issues

Is duplicate of Emulator - Emulator Issues #7143: DualCore timing issuesNew

History

#1 Updated by JMC4789 about 2 years ago

  • Status changed from New to Questionable

Dualcore allows the host state to leak into various games. In this particular case, it seems as though Dolphin isn't able to detect idleskipping, where it usually syncs the threads, so they're both running pretty much unsynced.

Enabling SyncGPU may help with this situation. I know it's frustrating, but, some of these bugs are built into the design of Dualcore in order to give the performance it can give. If single core works better, just use that, as it has the more accurate GPU timings in the first place.

I'm leaving this open because it does sound slightly strange, and I can't conclude what's going on without having the game to try myself. It is possible that there's a bug that can be fixed, though it is highly unlikely.

#2 Updated by JMC4789 over 1 year ago

  • Status changed from Questionable to Duplicate

No one investigated it, so merging it in with the other dualcore issues.

#3 Updated by JMC4789 over 1 year ago

#4 Updated by kolano over 1 year ago

Issues with this particular title are reported as addressed on it's Forum page...
https://forums.dolphin-emu.org/Thread-gc-second-sight?pid=479742#pid479742

Unclear if that's random or some general dual core issue has been resolved.

#5 Updated by xerxes 10 months ago

kolano That was with dual core disabled, which worked fine before. It still chugs with dual core enabled in 5.0-9795.

#6 Updated by JMC4789 10 months ago

I'm wondering if the game just doesn't lag on console, as the more I've tested games. Or maybe it's just laggier while loading stuff which is also normal.

Also available in: Atom PDF